summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/debian/changelog/changelog-file-general/build-spec/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/checks/debian/changelog/changelog-file-general/build-spec/debian/rules')
-rwxr-xr-xt/recipes/checks/debian/changelog/changelog-file-general/build-spec/debian/rules10
1 files changed, 10 insertions, 0 deletions
diff --git a/t/recipes/checks/debian/changelog/changelog-file-general/build-spec/debian/rules b/t/recipes/checks/debian/changelog/changelog-file-general/build-spec/debian/rules
new file mode 100755
index 0000000..9171128
--- /dev/null
+++ b/t/recipes/checks/debian/changelog/changelog-file-general/build-spec/debian/rules
@@ -0,0 +1,10 @@
+#!/usr/bin/make -f
+pkg = $(shell dh_listpackages)
+
+%:
+ dh $@
+
+override_dh_installchangelogs:
+ install -c -m 644 debian/changelog \
+ debian/$(pkg)/usr/share/doc/$(pkg)/changelog.Debian
+ gzip -1 -n debian/$(pkg)/usr/share/doc/$(pkg)/changelog.Debian