summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/debian/changelog/changelog-file-unreleased-signed-changes/build-spec/post-build.in
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/checks/debian/changelog/changelog-file-unreleased-signed-changes/build-spec/post-build.in')
-rwxr-xr-xt/recipes/checks/debian/changelog/changelog-file-unreleased-signed-changes/build-spec/post-build.in24
1 files changed, 24 insertions, 0 deletions
diff --git a/t/recipes/checks/debian/changelog/changelog-file-unreleased-signed-changes/build-spec/post-build.in b/t/recipes/checks/debian/changelog/changelog-file-unreleased-signed-changes/build-spec/post-build.in
new file mode 100755
index 0000000..95e78e4
--- /dev/null
+++ b/t/recipes/checks/debian/changelog/changelog-file-unreleased-signed-changes/build-spec/post-build.in
@@ -0,0 +1,24 @@
+#!/bin/sh
+
+set -e
+
+# create a temporary directory
+TEMPDIR=`mktemp -d`
+
+# import public key
+gpg --homedir "$TEMPDIR" --import "[% $source_path %]/public.key"
+
+# import private key
+gpg --homedir "$TEMPDIR" --allow-secret-key-import --import "[% $source_path %]/private.key"
+
+# sign changes file
+gpg --homedir "$TEMPDIR" --clearsign "[% $build_product %]"
+
+# save unsigned changes file elsewhere
+mv "[% $build_product %]" "[% $build_product %].unsigned"
+
+# move signed changes file to expected location
+mv "[% $build_product %].asc" "[% $build_product %]"
+
+# remove the temporary directory
+rm -rf "$TEMPDIR"