summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/debian/control/field/adopted/control-file-golang-xs-go-import-path
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/checks/debian/control/field/adopted/control-file-golang-xs-go-import-path')
-rw-r--r--t/recipes/checks/debian/control/field/adopted/control-file-golang-xs-go-import-path/build-spec/debian/control-file-golang-xs-go-import-path.install1
-rw-r--r--t/recipes/checks/debian/control/field/adopted/control-file-golang-xs-go-import-path/build-spec/debian/control.in42
-rw-r--r--t/recipes/checks/debian/control/field/adopted/control-file-golang-xs-go-import-path/build-spec/fill-values4
-rw-r--r--t/recipes/checks/debian/control/field/adopted/control-file-golang-xs-go-import-path/build-spec/orig/Makefile12
-rw-r--r--t/recipes/checks/debian/control/field/adopted/control-file-golang-xs-go-import-path/build-spec/orig/basic.c12
-rw-r--r--t/recipes/checks/debian/control/field/adopted/control-file-golang-xs-go-import-path/eval/desc3
-rw-r--r--t/recipes/checks/debian/control/field/adopted/control-file-golang-xs-go-import-path/eval/hint0
-rw-r--r--t/recipes/checks/debian/control/field/adopted/control-file-golang-xs-go-import-path/eval/hints0
8 files changed, 74 insertions, 0 deletions
diff --git a/t/recipes/checks/debian/control/field/adopted/control-file-golang-xs-go-import-path/build-spec/debian/control-file-golang-xs-go-import-path.install b/t/recipes/checks/debian/control/field/adopted/control-file-golang-xs-go-import-path/build-spec/debian/control-file-golang-xs-go-import-path.install
new file mode 100644
index 0000000..0ba75d6
--- /dev/null
+++ b/t/recipes/checks/debian/control/field/adopted/control-file-golang-xs-go-import-path/build-spec/debian/control-file-golang-xs-go-import-path.install
@@ -0,0 +1 @@
+static usr/lib/foo/
diff --git a/t/recipes/checks/debian/control/field/adopted/control-file-golang-xs-go-import-path/build-spec/debian/control.in b/t/recipes/checks/debian/control/field/adopted/control-file-golang-xs-go-import-path/build-spec/debian/control.in
new file mode 100644
index 0000000..65425a5
--- /dev/null
+++ b/t/recipes/checks/debian/control/field/adopted/control-file-golang-xs-go-import-path/build-spec/debian/control.in
@@ -0,0 +1,42 @@
+Source: [% $source %]
+Section: net
+Priority: optional
+Maintainer: [% $author %]
+Standards-Version: [% $standards_version %]
+Rules-Requires-Root: [% $rules_requires_root %]
+Build-Depends: [% $build_depends %],
+ golang-go (>= 2:1.1.1-4)
+XS-Go-Import-Path: github.com/Debian/lintian-test-package
+Go-Import-Path: github.com/Debian/lintian-test-package
+
+Package: [% $source %]
+Architecture: [% $package_architecture %]
+Depends: ${misc:Depends}
+Built-Using: ${misc:Built-Using}
+Description: [% $description %]
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package. It may
+ be an empty package.
+
+Package: [% $source %]-dev
+Architecture: all
+Depends: ${misc:Depends}
+Description: [% $description %] (dev)
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package. It may
+ be an empty package.
+ .
+ This package contains the source.
+
+Package: [% $source %]-clean-dev
+Architecture: all
+Depends: ${misc:Depends}
+Description: [% $description %] (clean dev)
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package. It may
+ be an empty package.
+ .
+ This package contains the source, without a built-using tag.
diff --git a/t/recipes/checks/debian/control/field/adopted/control-file-golang-xs-go-import-path/build-spec/fill-values b/t/recipes/checks/debian/control/field/adopted/control-file-golang-xs-go-import-path/build-spec/fill-values
new file mode 100644
index 0000000..130e255
--- /dev/null
+++ b/t/recipes/checks/debian/control/field/adopted/control-file-golang-xs-go-import-path/build-spec/fill-values
@@ -0,0 +1,4 @@
+Skeleton: upload-native
+Testname: control-file-golang-xs-go-import-path
+Description: False-positive test for XS-Go-Import field
+Package-Architecture: any
diff --git a/t/recipes/checks/debian/control/field/adopted/control-file-golang-xs-go-import-path/build-spec/orig/Makefile b/t/recipes/checks/debian/control/field/adopted/control-file-golang-xs-go-import-path/build-spec/orig/Makefile
new file mode 100644
index 0000000..6047afb
--- /dev/null
+++ b/t/recipes/checks/debian/control/field/adopted/control-file-golang-xs-go-import-path/build-spec/orig/Makefile
@@ -0,0 +1,12 @@
+NOPIE_CFLAGS = $(filter-out -fPIE,$(CFLAGS))
+NOPIE_LDFLAGS = $(filter-out -fPIE -pie,$(LDFLAGS))
+COMPILE:= $(CC) $(NOPIE_CFLAGS) $(CPPFLAGS) $(NOPIE_LDFLAGS)
+
+all:
+ # static version
+ $(COMPILE) -static -o static basic.c
+
+clean distclean:
+ rm -f basic
+
+check test:
diff --git a/t/recipes/checks/debian/control/field/adopted/control-file-golang-xs-go-import-path/build-spec/orig/basic.c b/t/recipes/checks/debian/control/field/adopted/control-file-golang-xs-go-import-path/build-spec/orig/basic.c
new file mode 100644
index 0000000..7dea5a0
--- /dev/null
+++ b/t/recipes/checks/debian/control/field/adopted/control-file-golang-xs-go-import-path/build-spec/orig/basic.c
@@ -0,0 +1,12 @@
+#include <stdio.h>
+
+int
+main(void)
+{
+ char t[10];
+ printf("Hello world!\n");
+ /* Bad choice for reading from stdin, but it forces a stack
+ protector, so meh.
+ */
+ gets (t);
+}
diff --git a/t/recipes/checks/debian/control/field/adopted/control-file-golang-xs-go-import-path/eval/desc b/t/recipes/checks/debian/control/field/adopted/control-file-golang-xs-go-import-path/eval/desc
new file mode 100644
index 0000000..c5ce740
--- /dev/null
+++ b/t/recipes/checks/debian/control/field/adopted/control-file-golang-xs-go-import-path/eval/desc
@@ -0,0 +1,3 @@
+Testname: control-file-golang-xs-go-import-path
+Test-Against: adopted-extended-field
+Check: debian/control/field/adopted
diff --git a/t/recipes/checks/debian/control/field/adopted/control-file-golang-xs-go-import-path/eval/hint b/t/recipes/checks/debian/control/field/adopted/control-file-golang-xs-go-import-path/eval/hint
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/t/recipes/checks/debian/control/field/adopted/control-file-golang-xs-go-import-path/eval/hint
diff --git a/t/recipes/checks/debian/control/field/adopted/control-file-golang-xs-go-import-path/eval/hints b/t/recipes/checks/debian/control/field/adopted/control-file-golang-xs-go-import-path/eval/hints
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/t/recipes/checks/debian/control/field/adopted/control-file-golang-xs-go-import-path/eval/hints