summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/debian/copyright/copyright-file-symlink
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/checks/debian/copyright/copyright-file-symlink')
-rw-r--r--t/recipes/checks/debian/copyright/copyright-file-symlink/build-spec/debian/control.in40
-rw-r--r--t/recipes/checks/debian/copyright/copyright-file-symlink/build-spec/debian/rules22
-rw-r--r--t/recipes/checks/debian/copyright/copyright-file-symlink/build-spec/fill-values3
-rw-r--r--t/recipes/checks/debian/copyright/copyright-file-symlink/eval/desc2
-rw-r--r--t/recipes/checks/debian/copyright/copyright-file-symlink/eval/hints3
5 files changed, 70 insertions, 0 deletions
diff --git a/t/recipes/checks/debian/copyright/copyright-file-symlink/build-spec/debian/control.in b/t/recipes/checks/debian/copyright/copyright-file-symlink/build-spec/debian/control.in
new file mode 100644
index 0000000..fb4666c
--- /dev/null
+++ b/t/recipes/checks/debian/copyright/copyright-file-symlink/build-spec/debian/control.in
@@ -0,0 +1,40 @@
+Source: [% $source %]
+Priority: optional
+Section: [% $section %]
+Maintainer: [% $author %]
+Standards-Version: [% $standards_version %]
+Build-Depends: [% $build_depends %]
+Rules-Requires-Root: no
+
+Package: symlink-to-foreign
+Architecture: all
+Depends: ${misc:Depends}, foreign-package
+Description: [% $description %] (foreign)
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package. It may
+ be an empty package.
+ .
+ Foreign.
+
+Package: symlink-outside-usd
+Architecture: all
+Depends: ${misc:Depends}
+Description: [% $description %] (usd)
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package. It may
+ be an empty package.
+ .
+ USD.
+
+Package: symlink-without-depends
+Architecture: all
+Depends: ${misc:Depends}
+Description: [% $description %] (no-deepnds)
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package. It may
+ be an empty package.
+ .
+ Symlinks without dependency.
diff --git a/t/recipes/checks/debian/copyright/copyright-file-symlink/build-spec/debian/rules b/t/recipes/checks/debian/copyright/copyright-file-symlink/build-spec/debian/rules
new file mode 100644
index 0000000..d48f723
--- /dev/null
+++ b/t/recipes/checks/debian/copyright/copyright-file-symlink/build-spec/debian/rules
@@ -0,0 +1,22 @@
+#!/usr/bin/make -f
+
+USD:=usr/share/doc
+%:
+ dh $@
+
+
+override_dh_md5sums:
+ rm -fr debian/symlink-to-foreign/$(USD)/symlink-to-foreign
+ ln -sf foreign-package \
+ debian/symlink-to-foreign/$(USD)/symlink-to-foreign
+ rm -fr debian/symlink-without-depends/$(USD)/symlink-without-depends
+ ln -sf foreign-package \
+ debian/symlink-without-depends/$(USD)/symlink-without-depends
+ # Move all of it to usr/lib/<package>/
+ mkdir -p debian/symlink-outside-usd/usr/lib/
+ mv debian/symlink-outside-usd/$(USD)/symlink-outside-usd \
+ debian/symlink-outside-usd/usr/lib/symlink-outside-usd/
+ # with symlink of course :)
+ ln -s ../../lib/symlink-outside-usd/copyright \
+ debian/symlink-outside-usd/$(USD)/symlink-outside-usd
+ dh_md5sums
diff --git a/t/recipes/checks/debian/copyright/copyright-file-symlink/build-spec/fill-values b/t/recipes/checks/debian/copyright/copyright-file-symlink/build-spec/fill-values
new file mode 100644
index 0000000..f286c24
--- /dev/null
+++ b/t/recipes/checks/debian/copyright/copyright-file-symlink/build-spec/fill-values
@@ -0,0 +1,3 @@
+Skeleton: upload-native
+Testname: copyright-file-symlink
+Description: Test for symlinked doc directories
diff --git a/t/recipes/checks/debian/copyright/copyright-file-symlink/eval/desc b/t/recipes/checks/debian/copyright/copyright-file-symlink/eval/desc
new file mode 100644
index 0000000..4f60c40
--- /dev/null
+++ b/t/recipes/checks/debian/copyright/copyright-file-symlink/eval/desc
@@ -0,0 +1,2 @@
+Testname: copyright-file-symlink
+Check: debian/copyright
diff --git a/t/recipes/checks/debian/copyright/copyright-file-symlink/eval/hints b/t/recipes/checks/debian/copyright/copyright-file-symlink/eval/hints
new file mode 100644
index 0000000..785fbc3
--- /dev/null
+++ b/t/recipes/checks/debian/copyright/copyright-file-symlink/eval/hints
@@ -0,0 +1,3 @@
+symlink-without-depends (binary): usr-share-doc-symlink-without-dependency foreign-package
+symlink-to-foreign (binary): usr-share-doc-symlink-to-foreign-package foreign-package
+symlink-outside-usd (binary): usr-share-doc-symlink-points-outside-of-usr-share-doc ../../lib/symlink-outside-usd/copyright [usr/share/doc/symlink-outside-usd]