summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/debian/debconf/debconf-maintscripts-deps/build-spec/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/checks/debian/debconf/debconf-maintscripts-deps/build-spec/debian/rules')
-rw-r--r--t/recipes/checks/debian/debconf/debconf-maintscripts-deps/build-spec/debian/rules16
1 files changed, 16 insertions, 0 deletions
diff --git a/t/recipes/checks/debian/debconf/debconf-maintscripts-deps/build-spec/debian/rules b/t/recipes/checks/debian/debconf/debconf-maintscripts-deps/build-spec/debian/rules
new file mode 100644
index 0000000..e1f0e1b
--- /dev/null
+++ b/t/recipes/checks/debian/debconf/debconf-maintscripts-deps/build-spec/debian/rules
@@ -0,0 +1,16 @@
+#!/usr/bin/make -f
+
+PKG=debian/$(shell dh_listpackages)
+
+%:
+ dh $@
+
+override_dh_builddeb:
+ # Manually copy the scripts - otherwise debhelper with insert
+ # the "correct magic" in each of them.
+ cp -a debian/preinst debian/postinst debian/postrm "$(PKG)/DEBIAN"
+ chmod 0755 "$(PKG)/DEBIAN/preinst" "$(PKG)/DEBIAN/postinst" \
+ "$(PKG)/DEBIAN/postrm"
+ sed -i '/#DEBHELPER#/ d' "$(PKG)/DEBIAN/preinst" \
+ "$(PKG)/DEBIAN/postinst" "$(PKG)/DEBIAN/postrm"
+ dh_builddeb