summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/debian/rules/rules-not-makefile/build-spec
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/checks/debian/rules/rules-not-makefile/build-spec')
-rwxr-xr-xt/recipes/checks/debian/rules/rules-not-makefile/build-spec/debian/rules13
-rw-r--r--t/recipes/checks/debian/rules/rules-not-makefile/build-spec/fill-values3
2 files changed, 16 insertions, 0 deletions
diff --git a/t/recipes/checks/debian/rules/rules-not-makefile/build-spec/debian/rules b/t/recipes/checks/debian/rules/rules-not-makefile/build-spec/debian/rules
new file mode 100755
index 0000000..97e5f8d
--- /dev/null
+++ b/t/recipes/checks/debian/rules/rules-not-makefile/build-spec/debian/rules
@@ -0,0 +1,13 @@
+#!/bin/sh
+# This should be a makefile.
+exec dh "$@"
+
+# fake targets to trick lintian into believing the
+# required targets are present (removed unrelated errors).
+binary:
+binary-arch:
+binary-indep:
+build:
+build-arch:
+build-indep:
+clean:
diff --git a/t/recipes/checks/debian/rules/rules-not-makefile/build-spec/fill-values b/t/recipes/checks/debian/rules/rules-not-makefile/build-spec/fill-values
new file mode 100644
index 0000000..33a94d1
--- /dev/null
+++ b/t/recipes/checks/debian/rules/rules-not-makefile/build-spec/fill-values
@@ -0,0 +1,3 @@
+Skeleton: upload-native
+Testname: rules-not-makefile
+Description: Check if the rules file is a makefile