summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/debian/shlibs/binaries-multiarch-same/build-spec/orig
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/checks/debian/shlibs/binaries-multiarch-same/build-spec/orig')
-rw-r--r--t/recipes/checks/debian/shlibs/binaries-multiarch-same/build-spec/orig/Makefile12
-rw-r--r--t/recipes/checks/debian/shlibs/binaries-multiarch-same/build-spec/orig/basic.c19
2 files changed, 31 insertions, 0 deletions
diff --git a/t/recipes/checks/debian/shlibs/binaries-multiarch-same/build-spec/orig/Makefile b/t/recipes/checks/debian/shlibs/binaries-multiarch-same/build-spec/orig/Makefile
new file mode 100644
index 0000000..ad7783b
--- /dev/null
+++ b/t/recipes/checks/debian/shlibs/binaries-multiarch-same/build-spec/orig/Makefile
@@ -0,0 +1,12 @@
+
+all:
+ gcc $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -fPIC -shared -Wl,-z,defs -Wl,-soname,libbasic.so.2 -o libbasic.so.2 basic.c
+
+install:
+ install -d $(DESTDIR)/usr/lib/
+ install -m 644 -c -s libbasic.so.2 $(DESTDIR)/usr/lib/libbasic.so.2
+
+clean distclean:
+ rm -f libbasic.so.2
+
+check test:
diff --git a/t/recipes/checks/debian/shlibs/binaries-multiarch-same/build-spec/orig/basic.c b/t/recipes/checks/debian/shlibs/binaries-multiarch-same/build-spec/orig/basic.c
new file mode 100644
index 0000000..27e93fc
--- /dev/null
+++ b/t/recipes/checks/debian/shlibs/binaries-multiarch-same/build-spec/orig/basic.c
@@ -0,0 +1,19 @@
+#include <stdio.h>
+#include <string.h>
+
+static void
+hardening_trigger(char *p, int i, void (*f)(char *))
+{
+ char test[10];
+ memcpy(test, p, i);
+ f(test);
+ printf("%s", test);
+}
+
+int
+lib_interface(void)
+{
+ printf("Hello world!\n");
+ hardening_trigger(NULL, 0, NULL);
+ return 0;
+}