summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/debian/shlibs/binaries-multiarch/build-spec/orig/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/checks/debian/shlibs/binaries-multiarch/build-spec/orig/Makefile')
-rw-r--r--t/recipes/checks/debian/shlibs/binaries-multiarch/build-spec/orig/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/t/recipes/checks/debian/shlibs/binaries-multiarch/build-spec/orig/Makefile b/t/recipes/checks/debian/shlibs/binaries-multiarch/build-spec/orig/Makefile
new file mode 100644
index 0000000..979e366
--- /dev/null
+++ b/t/recipes/checks/debian/shlibs/binaries-multiarch/build-spec/orig/Makefile
@@ -0,0 +1,26 @@
+
+# Since dpkg in stable (Squeeze) does not support MULTIARCH we cannot use
+# dpkg-architecture -qDEB_HOST_MULTIARCH
+# Therefore this test is hardcoded to x86 and amd64
+
+ARCH=$(shell dpkg-architecture -qDEB_HOST_ARCH)
+
+ifeq (i386,$(ARCH))
+ TRIPLET = i386-linux-gnu
+else
+ TRIPLET = x86_64-linux-gnu
+endif
+
+
+all:
+ gcc $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -fPIC -shared -Wl,-z,defs -Wl,-soname,libbasic.so.2 -o libbasic.so.2 basic.c
+
+install:
+ # install it under the correct triplet directory
+ install -d $(DESTDIR)/usr/lib/$(TRIPLET)
+ install -m 644 -c -s libbasic.so.2 $(DESTDIR)/usr/lib/$(TRIPLET)/libbasic.so.2
+
+clean distclean:
+ rm -f libbasic.so.2
+
+check test: