summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/debian/shlibs/shared-libs-unversioned/build-spec/orig/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/checks/debian/shlibs/shared-libs-unversioned/build-spec/orig/Makefile')
-rw-r--r--t/recipes/checks/debian/shlibs/shared-libs-unversioned/build-spec/orig/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/t/recipes/checks/debian/shlibs/shared-libs-unversioned/build-spec/orig/Makefile b/t/recipes/checks/debian/shlibs/shared-libs-unversioned/build-spec/orig/Makefile
new file mode 100644
index 0000000..daf74d1
--- /dev/null
+++ b/t/recipes/checks/debian/shlibs/shared-libs-unversioned/build-spec/orig/Makefile
@@ -0,0 +1,15 @@
+CC = gcc
+
+all: libfoo.so
+
+libfoo.so: foo.o
+ $(CC) $(LDFLAGS) -o $@ -shared -Wl,-soname,libfoo.so $^ -lc
+
+%.o: %.c
+ $(CC) $(CFLAGS) $(CPPFLAGS) -fPIC -o $@ -c $<
+
+install:
+ install -d $(DESTDIR)/usr/lib
+ install -m644 libfoo.so $(DESTDIR)/usr/lib/
+
+.PHONY: distclean realclean clean install test check