summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/documentation/files-python-general/build-spec/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/checks/documentation/files-python-general/build-spec/debian/rules')
-rw-r--r--t/recipes/checks/documentation/files-python-general/build-spec/debian/rules19
1 files changed, 19 insertions, 0 deletions
diff --git a/t/recipes/checks/documentation/files-python-general/build-spec/debian/rules b/t/recipes/checks/documentation/files-python-general/build-spec/debian/rules
new file mode 100644
index 0000000..1648ccd
--- /dev/null
+++ b/t/recipes/checks/documentation/files-python-general/build-spec/debian/rules
@@ -0,0 +1,19 @@
+#!/usr/bin/make -f
+
+export DEB_BUILD_MAINT_OPTIONS=hardening=+all
+DPKG_EXPORT_BUILDFLAGS:=1
+include /usr/share/dpkg/buildflags.mk
+
+DOCS:=debian/python-kinterbasdb/usr/share/doc/python-kinterbasdb/docs
+%:
+ dh $@
+
+override_dh_strip:
+ dh_strip -ppython-kinterbasdb --dbg-package=python-kinterbasdb-dbg
+ dh_strip --remaining-packages
+
+override_dh_compress:
+ dh_compress
+ # Manually compress it, since debhelper will fix #608907
+ # in the "near" future.
+ [ -f "$(DOCS)/objects.inv.gz" ] || gzip -n --best "$(DOCS)/objects.inv"