summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/documentation/files-zero-byte-doc/build-spec/orig/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/checks/documentation/files-zero-byte-doc/build-spec/orig/Makefile')
-rw-r--r--t/recipes/checks/documentation/files-zero-byte-doc/build-spec/orig/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/t/recipes/checks/documentation/files-zero-byte-doc/build-spec/orig/Makefile b/t/recipes/checks/documentation/files-zero-byte-doc/build-spec/orig/Makefile
new file mode 100644
index 0000000..3f77ca4
--- /dev/null
+++ b/t/recipes/checks/documentation/files-zero-byte-doc/build-spec/orig/Makefile
@@ -0,0 +1,29 @@
+ROOT = $(DESTDIR)/usr/share/doc/files-zero-byte-doc
+
+default:
+ :
+
+install:
+ mkdir -p $(ROOT)
+ # Should be ignored.
+ mkdir -p $(ROOT)/examples
+ touch $(ROOT)/examples/empty
+ touch $(ROOT)/__init__.py
+ mkdir -p $(ROOT)/python/foo
+ touch $(ROOT)/python/foo/__init__.py
+ mkdir -p $(ROOT)/html
+ touch $(ROOT)/html/blah.map
+ mkdir -p $(ROOT)/manual/1/html/foo
+ touch $(ROOT)/manual/1/html/foo/blah.map
+ # Should be diagnosed.
+ touch $(ROOT)/NEWS
+ touch $(ROOT)/foo__init__.py
+ touch $(ROOT)/html.map
+ touch $(ROOT)/htmlfoo.map
+ mkdir -p $(ROOT)/manual
+ touch $(ROOT)/manual/foo.map
+ gzip -n -9 $(ROOT)/manual/foo.map
+ touch $(ROOT)/some-really-long-file-name-to-make-the-gzip-file-larger
+ gzip -n -9 $(ROOT)/some-really-long-file-name-to-make-the-gzip-file-larger
+
+.PHONY: clean distclean realclean install check test