summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/documentation/manual/manpage-not-compressed-with-gzip/build-spec/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/checks/documentation/manual/manpage-not-compressed-with-gzip/build-spec/debian/rules')
-rwxr-xr-xt/recipes/checks/documentation/manual/manpage-not-compressed-with-gzip/build-spec/debian/rules10
1 files changed, 10 insertions, 0 deletions
diff --git a/t/recipes/checks/documentation/manual/manpage-not-compressed-with-gzip/build-spec/debian/rules b/t/recipes/checks/documentation/manual/manpage-not-compressed-with-gzip/build-spec/debian/rules
new file mode 100755
index 0000000..cf58556
--- /dev/null
+++ b/t/recipes/checks/documentation/manual/manpage-not-compressed-with-gzip/build-spec/debian/rules
@@ -0,0 +1,10 @@
+#!/usr/bin/make -f
+
+tmp := $(CURDIR)/debian/$(shell dh_listpackages)
+
+%:
+ dh $@
+
+override_dh_compress:
+ dh_compress --exclude=pretend-compress.1
+ mv $(tmp)/usr/share/man/man1/pretend-compress.1 $(tmp)/usr/share/man/man1/pretend-compress.1.gz