summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/documentation/manual/manpages-wrong-dir/build-spec/orig/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/checks/documentation/manual/manpages-wrong-dir/build-spec/orig/Makefile')
-rw-r--r--t/recipes/checks/documentation/manual/manpages-wrong-dir/build-spec/orig/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/t/recipes/checks/documentation/manual/manpages-wrong-dir/build-spec/orig/Makefile b/t/recipes/checks/documentation/manual/manpages-wrong-dir/build-spec/orig/Makefile
new file mode 100644
index 0000000..cff6c32
--- /dev/null
+++ b/t/recipes/checks/documentation/manual/manpages-wrong-dir/build-spec/orig/Makefile
@@ -0,0 +1,14 @@
+all: pecho.1.gz zecho.1.gz
+
+%.gz: %
+ gzip --best $<
+
+%.1: %
+ pod2man --section 1 $< > $@
+
+zecho: pecho
+ sed s/$</$@/g $< > $@
+ chmod 0755 $@
+
+clean:
+ rm -f pecho.1.gz zecho*