summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/documentation/manual/manpages-wrong-dir/build-spec
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/checks/documentation/manual/manpages-wrong-dir/build-spec')
-rw-r--r--t/recipes/checks/documentation/manual/manpages-wrong-dir/build-spec/debian/install2
-rw-r--r--t/recipes/checks/documentation/manual/manpages-wrong-dir/build-spec/fill-values3
-rw-r--r--t/recipes/checks/documentation/manual/manpages-wrong-dir/build-spec/orig/Makefile14
-rw-r--r--t/recipes/checks/documentation/manual/manpages-wrong-dir/build-spec/orig/pecho25
4 files changed, 44 insertions, 0 deletions
diff --git a/t/recipes/checks/documentation/manual/manpages-wrong-dir/build-spec/debian/install b/t/recipes/checks/documentation/manual/manpages-wrong-dir/build-spec/debian/install
new file mode 100644
index 0000000..ad89b63
--- /dev/null
+++ b/t/recipes/checks/documentation/manual/manpages-wrong-dir/build-spec/debian/install
@@ -0,0 +1,2 @@
+zecho.1.gz usr/share/man
+zecho.1.gz usr/share/man/man-lintian
diff --git a/t/recipes/checks/documentation/manual/manpages-wrong-dir/build-spec/fill-values b/t/recipes/checks/documentation/manual/manpages-wrong-dir/build-spec/fill-values
new file mode 100644
index 0000000..35e0a12
--- /dev/null
+++ b/t/recipes/checks/documentation/manual/manpages-wrong-dir/build-spec/fill-values
@@ -0,0 +1,3 @@
+Skeleton: upload-native
+Testname: manpages-wrong-dir
+Description: Test for manpages in wrong dirs
diff --git a/t/recipes/checks/documentation/manual/manpages-wrong-dir/build-spec/orig/Makefile b/t/recipes/checks/documentation/manual/manpages-wrong-dir/build-spec/orig/Makefile
new file mode 100644
index 0000000..cff6c32
--- /dev/null
+++ b/t/recipes/checks/documentation/manual/manpages-wrong-dir/build-spec/orig/Makefile
@@ -0,0 +1,14 @@
+all: pecho.1.gz zecho.1.gz
+
+%.gz: %
+ gzip --best $<
+
+%.1: %
+ pod2man --section 1 $< > $@
+
+zecho: pecho
+ sed s/$</$@/g $< > $@
+ chmod 0755 $@
+
+clean:
+ rm -f pecho.1.gz zecho*
diff --git a/t/recipes/checks/documentation/manual/manpages-wrong-dir/build-spec/orig/pecho b/t/recipes/checks/documentation/manual/manpages-wrong-dir/build-spec/orig/pecho
new file mode 100644
index 0000000..d982088
--- /dev/null
+++ b/t/recipes/checks/documentation/manual/manpages-wrong-dir/build-spec/orig/pecho
@@ -0,0 +1,25 @@
+#!/usr/bin/perl
+
+use strict;
+use warnings;
+
+print join(' ', @ARGV), "\n";
+
+=head1 NAME
+
+pecho - POSIX compliant Perl implementation of echo
+
+=head1 SYNOPSIS
+
+pecho [args ...]
+
+=head1 DESCRIPTION
+
+Prints arguments to stdout.
+
+=head1 AUTHORS
+
+Niels Thykier <niels@thykier.net>
+
+=cut
+