summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/executable/files-zero-byte-executable-in-path/build-spec/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/checks/executable/files-zero-byte-executable-in-path/build-spec/debian/rules')
-rw-r--r--t/recipes/checks/executable/files-zero-byte-executable-in-path/build-spec/debian/rules10
1 files changed, 10 insertions, 0 deletions
diff --git a/t/recipes/checks/executable/files-zero-byte-executable-in-path/build-spec/debian/rules b/t/recipes/checks/executable/files-zero-byte-executable-in-path/build-spec/debian/rules
new file mode 100644
index 0000000..ed45d82
--- /dev/null
+++ b/t/recipes/checks/executable/files-zero-byte-executable-in-path/build-spec/debian/rules
@@ -0,0 +1,10 @@
+#!/usr/bin/make -f
+
+DIR := debian/$(shell dh_listpackages)/usr/bin
+
+%:
+ dh $@
+
+override_dh_auto_install:
+ mkdir -p $(DIR)
+ touch $(DIR)/empty-executable