summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/fields/standards-version/legacy-debconf/build-spec/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/checks/fields/standards-version/legacy-debconf/build-spec/debian/rules')
-rwxr-xr-xt/recipes/checks/fields/standards-version/legacy-debconf/build-spec/debian/rules64
1 files changed, 64 insertions, 0 deletions
diff --git a/t/recipes/checks/fields/standards-version/legacy-debconf/build-spec/debian/rules b/t/recipes/checks/fields/standards-version/legacy-debconf/build-spec/debian/rules
new file mode 100755
index 0000000..933901a
--- /dev/null
+++ b/t/recipes/checks/fields/standards-version/legacy-debconf/build-spec/debian/rules
@@ -0,0 +1,64 @@
+#!/usr/bin/make -f
+
+deb_dir = debian/debconf
+udeb_dir = debian/debconf-udeb
+build_dirs = $(deb_dir) $(udeb_dir)
+
+build-indep:
+# There are no architecture-independent files to be built
+# by this package. If there were any they would be made
+# here.
+
+build-arch:
+ dh_testdir
+ touch build
+
+build: build-indep build-arch
+
+clean:
+ dh_testdir
+ dh_testroot
+ -rm -f build
+
+ dh_clean
+
+binary-indep: build
+# There are no architecture-independent files to be uploaded
+# generated by this package. If there were any they would be
+# made here.
+
+binary-arch: build
+ dh_testdir
+ dh_testroot
+ dh_prep
+ dh_installdirs -a
+
+ dh_installchangelogs -a
+ dh_installdocs -a
+ dh_installdebconf -pdebconf-test
+ dh_installdebconf -pdebconf-test-noscripts --noscripts
+ dh_installdebconf -pdebconf-test-preinst --noscripts
+ dh_installdebconf -pdebconf-test-postinst --noscripts
+ dh_installdebconf -pdebconf-udeb
+
+
+
+
+ dh_compress -a
+ dh_fixperms -a
+
+# The shlibs stuff doesn't matter here so do it in a weird order to
+# test warnings.
+ dh_installdeb -a
+ dh_shlibdeps -a
+ dh_makeshlibs -a
+ dh_gencontrol -a
+ dh_md5sums
+ dh_builddeb -a
+ dh_makeshlibs -a
+
+# Below here is fairly generic really
+
+binary: binary-indep binary-arch
+
+.PHONY: build-arch build-indep build binary binary-arch binary-indep clean checkroot