summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/files/architecture/binaries-multiarch/build-spec/debian
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/checks/files/architecture/binaries-multiarch/build-spec/debian')
-rw-r--r--t/recipes/checks/files/architecture/binaries-multiarch/build-spec/debian/compat.in1
-rw-r--r--t/recipes/checks/files/architecture/binaries-multiarch/build-spec/debian/control.in21
-rw-r--r--t/recipes/checks/files/architecture/binaries-multiarch/build-spec/debian/libbasic2.symbols2
-rw-r--r--t/recipes/checks/files/architecture/binaries-multiarch/build-spec/debian/rules23
4 files changed, 47 insertions, 0 deletions
diff --git a/t/recipes/checks/files/architecture/binaries-multiarch/build-spec/debian/compat.in b/t/recipes/checks/files/architecture/binaries-multiarch/build-spec/debian/compat.in
new file mode 100644
index 0000000..640a566
--- /dev/null
+++ b/t/recipes/checks/files/architecture/binaries-multiarch/build-spec/debian/compat.in
@@ -0,0 +1 @@
+[% $dh_compat_level %]
diff --git a/t/recipes/checks/files/architecture/binaries-multiarch/build-spec/debian/control.in b/t/recipes/checks/files/architecture/binaries-multiarch/build-spec/debian/control.in
new file mode 100644
index 0000000..aa271ff
--- /dev/null
+++ b/t/recipes/checks/files/architecture/binaries-multiarch/build-spec/debian/control.in
@@ -0,0 +1,21 @@
+Source: [% $source %]
+Priority: optional
+Section: libs
+Maintainer: [% $author %]
+Standards-Version: [% $standards_version %]
+Build-Depends: [% $build_depends %]
+Rules-Requires-Root: no
+
+Package: libbasic2
+Architecture: [% $package_architecture %]
+Pre-Depends: ${misc:Pre-Depends}, multiarch-support
+Depends: ${misc:Depends}, ${shlibs:Depends}
+Description: [% $description %]
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package. It may
+ be an empty package.
+ .
+ Note there is an explicitly pre-depends on multiarch-support, since
+ older versions of debhelper might not use it yet. dpkg-dev will
+ remove the duplicate entry (if any).
diff --git a/t/recipes/checks/files/architecture/binaries-multiarch/build-spec/debian/libbasic2.symbols b/t/recipes/checks/files/architecture/binaries-multiarch/build-spec/debian/libbasic2.symbols
new file mode 100644
index 0000000..c2b8fb3
--- /dev/null
+++ b/t/recipes/checks/files/architecture/binaries-multiarch/build-spec/debian/libbasic2.symbols
@@ -0,0 +1,2 @@
+libbasic.so.2 libbasic2 #MINVER#
+ lib_interface@Base 1.0
diff --git a/t/recipes/checks/files/architecture/binaries-multiarch/build-spec/debian/rules b/t/recipes/checks/files/architecture/binaries-multiarch/build-spec/debian/rules
new file mode 100644
index 0000000..249fe25
--- /dev/null
+++ b/t/recipes/checks/files/architecture/binaries-multiarch/build-spec/debian/rules
@@ -0,0 +1,23 @@
+#!/usr/bin/make -f
+
+# Since dpkg in stable (Squeeze) does not support MULTIARCH we cannot use
+# dpkg-architecture -qDEB_HOST_MULTIARCH
+# Therefore this test is hardcoded to x86 and amd64
+
+ARCH=$(shell dpkg-architecture -qDEB_HOST_ARCH)
+
+ifeq (i386,$(ARCH))
+ TRIPLET = i386-linux-gnu
+else
+ TRIPLET = x86_64-linux-gnu
+endif
+
+export DEB_BUILD_MAINT_OPTIONS=hardening=+all
+
+%:
+ dh $@
+
+override_dh_makeshlibs:
+ # dpkg-dev uses ld.so.conf so if we do not pass the lib directly
+ # this will fail on all x86 machines without with libc6 < 2.13-5
+ dh_makeshlibs -- -edebian/libbasic2/usr/lib/$(TRIPLET)/libbasic.so.2