summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/files/contents/contains-build-path/build-spec/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/checks/files/contents/contains-build-path/build-spec/debian/rules')
-rwxr-xr-xt/recipes/checks/files/contents/contains-build-path/build-spec/debian/rules15
1 files changed, 15 insertions, 0 deletions
diff --git a/t/recipes/checks/files/contents/contains-build-path/build-spec/debian/rules b/t/recipes/checks/files/contents/contains-build-path/build-spec/debian/rules
new file mode 100755
index 0000000..1a1253b
--- /dev/null
+++ b/t/recipes/checks/files/contents/contains-build-path/build-spec/debian/rules
@@ -0,0 +1,15 @@
+#!/usr/bin/make -f
+
+export DEB_BUILD_MAINT_OPTIONS=hardening=+all
+
+tmp := $(CURDIR)/debian/$(shell dh_listpackages)
+
+%:
+ dh $@
+
+# In Ubuntu, dh does not catch this file by default.
+# They have diffed it to reduce the size of packages.
+ifneq (,$(strip $(wildcard Changes)))
+override_dh_installchangelogs:
+ dh_installchangelogs Changes
+endif