summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/files/hierarchy/links/usr-lib-to-opt/build-spec/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/checks/files/hierarchy/links/usr-lib-to-opt/build-spec/debian/rules')
-rwxr-xr-xt/recipes/checks/files/hierarchy/links/usr-lib-to-opt/build-spec/debian/rules18
1 files changed, 18 insertions, 0 deletions
diff --git a/t/recipes/checks/files/hierarchy/links/usr-lib-to-opt/build-spec/debian/rules b/t/recipes/checks/files/hierarchy/links/usr-lib-to-opt/build-spec/debian/rules
new file mode 100755
index 0000000..3bf6d2a
--- /dev/null
+++ b/t/recipes/checks/files/hierarchy/links/usr-lib-to-opt/build-spec/debian/rules
@@ -0,0 +1,18 @@
+#!/usr/bin/make -f
+
+export DEB_BUILD_MAINT_OPTIONS=hardening=+all
+
+%:
+ dh $@
+
+# must create here; *.so files are ignored by dpkg-source
+override_dh_auto_build:
+ mkdir modules
+ echo "A SHARED OBJECT" > modules/a-module.so
+
+# In Ubuntu, dh does not catch this file by default.
+# They have diffed it to reduce the size of packages.
+ifneq (,$(strip $(wildcard Changes)))
+override_dh_installchangelogs:
+ dh_installchangelogs Changes
+endif