summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/files/symbolic-links/broken/symlinks-unsafe/build-spec/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/checks/files/symbolic-links/broken/symlinks-unsafe/build-spec/debian/rules')
-rw-r--r--t/recipes/checks/files/symbolic-links/broken/symlinks-unsafe/build-spec/debian/rules14
1 files changed, 14 insertions, 0 deletions
diff --git a/t/recipes/checks/files/symbolic-links/broken/symlinks-unsafe/build-spec/debian/rules b/t/recipes/checks/files/symbolic-links/broken/symlinks-unsafe/build-spec/debian/rules
new file mode 100644
index 0000000..c2b7e3c
--- /dev/null
+++ b/t/recipes/checks/files/symbolic-links/broken/symlinks-unsafe/build-spec/debian/rules
@@ -0,0 +1,14 @@
+#!/usr/bin/make -f
+
+PKG:=$(shell dh_listpackages)
+LINK_DIR:=debian/$(PKG)/usr/share/lintian/bad-links
+LINK_TARGET:=non-existent/path/lintian-should-not-open
+
+%:
+ dh $@
+
+override_dh_link:
+ mkdir -p "$(LINK_DIR)"
+ ln -s ../../../../../$(LINK_TARGET) \
+ $(LINK_DIR)/relative-escape
+ ln -s /../$(LINK_TARGET) $(LINK_DIR)/absolute