summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/files/symbolic-links/files-symlink-points-to-tmp/build-spec/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/checks/files/symbolic-links/files-symlink-points-to-tmp/build-spec/debian/rules')
-rw-r--r--t/recipes/checks/files/symbolic-links/files-symlink-points-to-tmp/build-spec/debian/rules14
1 files changed, 14 insertions, 0 deletions
diff --git a/t/recipes/checks/files/symbolic-links/files-symlink-points-to-tmp/build-spec/debian/rules b/t/recipes/checks/files/symbolic-links/files-symlink-points-to-tmp/build-spec/debian/rules
new file mode 100644
index 0000000..e61f78e
--- /dev/null
+++ b/t/recipes/checks/files/symbolic-links/files-symlink-points-to-tmp/build-spec/debian/rules
@@ -0,0 +1,14 @@
+#!/usr/bin/make -f
+
+%:
+ dh $@
+
+override_dh_auto_build:
+ mkdir symlinks/
+ ln -s /tmp/does-not-exist symlinks/points-to-tmp
+
+override_dh_auto_clean:
+ rm -fr symlinks/
+
+override_dh_link:
+ # it will fix our symlinks and ruin the test, so skip it.