summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/group-checks/group-checks-circular-deps
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/checks/group-checks/group-checks-circular-deps')
-rw-r--r--t/recipes/checks/group-checks/group-checks-circular-deps/build-spec/debian/control.in99
-rw-r--r--t/recipes/checks/group-checks/group-checks-circular-deps/build-spec/debian/rules9
-rw-r--r--t/recipes/checks/group-checks/group-checks-circular-deps/build-spec/fill-values3
-rw-r--r--t/recipes/checks/group-checks/group-checks-circular-deps/build-spec/orig/some-doc.txt1
-rw-r--r--t/recipes/checks/group-checks/group-checks-circular-deps/eval/desc2
-rw-r--r--t/recipes/checks/group-checks/group-checks-circular-deps/eval/hints2
6 files changed, 116 insertions, 0 deletions
diff --git a/t/recipes/checks/group-checks/group-checks-circular-deps/build-spec/debian/control.in b/t/recipes/checks/group-checks/group-checks-circular-deps/build-spec/debian/control.in
new file mode 100644
index 0000000..0c93dc6
--- /dev/null
+++ b/t/recipes/checks/group-checks/group-checks-circular-deps/build-spec/debian/control.in
@@ -0,0 +1,99 @@
+Source: [% $source %]
+Priority: optional
+Section: [% $section %]
+Maintainer: [% $author %]
+Standards-Version: [% $standards_version %]
+Build-Depends: [% $build_depends %]
+Rules-Requires-Root: no
+
+Package: root
+Architecture: all
+Depends: ${misc:Depends}, c1-a, c1-c, c2-b
+Description: [% $description %] - root
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package.
+ .
+ root.
+
+Package: leaf
+Architecture: all
+Depends: ${misc:Depends}
+Description: [% $description %] - leaf
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package.
+ .
+ leaf.
+
+Package: disconnected
+Architecture: all
+Depends: ${misc:Depends}
+Description: [% $description %] - dis
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package.
+ .
+ disconnected.
+
+
+Package: c1-a
+Architecture: all
+Depends: ${misc:Depends}, c1-b, leaf
+Description: [% $description %] - c1-a
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package.
+ .
+ c1-a.
+
+Package: c1-b
+Architecture: all
+Depends: ${misc:Depends}, c1-c
+Description: [% $description %] - c1-b
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package.
+ .
+ c1-b.
+
+Package: c1-c
+Architecture: all
+Depends: ${misc:Depends}, c1-a, leaf
+Description: [% $description %] - c1-c
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package.
+ .
+ c1-c.
+
+Package: c2-a
+Architecture: all
+Depends: ${misc:Depends}, c2-b, c2-c, leaf
+Description: [% $description %] - c2-a
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package.
+ .
+ c2-a.
+
+Package: c2-b
+Architecture: all
+Depends: ${misc:Depends}, c2-a, c2-c
+Description: [% $description %] - c2-b
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package.
+ .
+ c2-b.
+
+Package: c2-c
+Architecture: all
+Depends: ${misc:Depends}, c2-a, c2-b, leaf
+Description: [% $description %] - c2-c
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package.
+ .
+ c2-c.
+
diff --git a/t/recipes/checks/group-checks/group-checks-circular-deps/build-spec/debian/rules b/t/recipes/checks/group-checks/group-checks-circular-deps/build-spec/debian/rules
new file mode 100644
index 0000000..644131e
--- /dev/null
+++ b/t/recipes/checks/group-checks/group-checks-circular-deps/build-spec/debian/rules
@@ -0,0 +1,9 @@
+#!/usr/bin/make -f
+
+%:
+ dh $@
+
+override_dh_installdocs:
+ for P in $$(dh_listpackages) ; do \
+ dh_installdocs -p$$P some-doc.txt || exit 1 ;\
+ done
diff --git a/t/recipes/checks/group-checks/group-checks-circular-deps/build-spec/fill-values b/t/recipes/checks/group-checks/group-checks-circular-deps/build-spec/fill-values
new file mode 100644
index 0000000..b8f1db5
--- /dev/null
+++ b/t/recipes/checks/group-checks/group-checks-circular-deps/build-spec/fill-values
@@ -0,0 +1,3 @@
+Skeleton: upload-native
+Testname: group-checks-circular-deps
+Description: Test for circular dependencies
diff --git a/t/recipes/checks/group-checks/group-checks-circular-deps/build-spec/orig/some-doc.txt b/t/recipes/checks/group-checks/group-checks-circular-deps/build-spec/orig/some-doc.txt
new file mode 100644
index 0000000..e845566
--- /dev/null
+++ b/t/recipes/checks/group-checks/group-checks-circular-deps/build-spec/orig/some-doc.txt
@@ -0,0 +1 @@
+README
diff --git a/t/recipes/checks/group-checks/group-checks-circular-deps/eval/desc b/t/recipes/checks/group-checks/group-checks-circular-deps/eval/desc
new file mode 100644
index 0000000..ad7cbe5
--- /dev/null
+++ b/t/recipes/checks/group-checks/group-checks-circular-deps/eval/desc
@@ -0,0 +1,2 @@
+Testname: group-checks-circular-deps
+Check: group-checks
diff --git a/t/recipes/checks/group-checks/group-checks-circular-deps/eval/hints b/t/recipes/checks/group-checks/group-checks-circular-deps/eval/hints
new file mode 100644
index 0000000..00c9bef
--- /dev/null
+++ b/t/recipes/checks/group-checks/group-checks-circular-deps/eval/hints
@@ -0,0 +1,2 @@
+group-checks-circular-deps (source): intra-source-package-circular-dependency c2-a c2-b c2-c
+group-checks-circular-deps (source): intra-source-package-circular-dependency c1-a c1-b c1-c