summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/group-checks/group-checks-file-conflict
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/checks/group-checks/group-checks-file-conflict')
-rw-r--r--t/recipes/checks/group-checks/group-checks-file-conflict/build-spec/debian/control.in27
-rw-r--r--t/recipes/checks/group-checks/group-checks-file-conflict/build-spec/debian/rules9
-rw-r--r--t/recipes/checks/group-checks/group-checks-file-conflict/build-spec/fill-values3
-rw-r--r--t/recipes/checks/group-checks/group-checks-file-conflict/build-spec/orig/data-file1
-rw-r--r--t/recipes/checks/group-checks/group-checks-file-conflict/eval/desc2
-rw-r--r--t/recipes/checks/group-checks/group-checks-file-conflict/eval/hints1
6 files changed, 43 insertions, 0 deletions
diff --git a/t/recipes/checks/group-checks/group-checks-file-conflict/build-spec/debian/control.in b/t/recipes/checks/group-checks/group-checks-file-conflict/build-spec/debian/control.in
new file mode 100644
index 0000000..6491675
--- /dev/null
+++ b/t/recipes/checks/group-checks/group-checks-file-conflict/build-spec/debian/control.in
@@ -0,0 +1,27 @@
+Source: [% $source %]
+Priority: optional
+Section: [% $section %]
+Maintainer: [% $author %]
+Standards-Version: [% $standards_version %]
+Build-Depends: [% $build_depends %]
+Rules-Requires-Root: no
+
+Package: pkga
+Architecture: all
+Depends: ${misc:Depends}
+Description: [% $description %] - pkga
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package.
+ .
+ pkga.
+
+Package: pkgb
+Architecture: all
+Depends: ${misc:Depends}
+Description: [% $description %] - pkgb
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package.
+ .
+ pkgb.
diff --git a/t/recipes/checks/group-checks/group-checks-file-conflict/build-spec/debian/rules b/t/recipes/checks/group-checks/group-checks-file-conflict/build-spec/debian/rules
new file mode 100644
index 0000000..8e256c8
--- /dev/null
+++ b/t/recipes/checks/group-checks/group-checks-file-conflict/build-spec/debian/rules
@@ -0,0 +1,9 @@
+#!/usr/bin/make -f
+
+%:
+ dh $@
+
+override_dh_install:
+ for P in $$(dh_listpackages) ; do \
+ dh_install -p$$P data-file usr/share/pkga/ || exit 1 ;\
+ done
diff --git a/t/recipes/checks/group-checks/group-checks-file-conflict/build-spec/fill-values b/t/recipes/checks/group-checks/group-checks-file-conflict/build-spec/fill-values
new file mode 100644
index 0000000..52da7a4
--- /dev/null
+++ b/t/recipes/checks/group-checks/group-checks-file-conflict/build-spec/fill-values
@@ -0,0 +1,3 @@
+Skeleton: upload-native
+Testname: group-checks-file-conflict
+Description: Test for overlapping files
diff --git a/t/recipes/checks/group-checks/group-checks-file-conflict/build-spec/orig/data-file b/t/recipes/checks/group-checks/group-checks-file-conflict/build-spec/orig/data-file
new file mode 100644
index 0000000..e845566
--- /dev/null
+++ b/t/recipes/checks/group-checks/group-checks-file-conflict/build-spec/orig/data-file
@@ -0,0 +1 @@
+README
diff --git a/t/recipes/checks/group-checks/group-checks-file-conflict/eval/desc b/t/recipes/checks/group-checks/group-checks-file-conflict/eval/desc
new file mode 100644
index 0000000..eb49a80
--- /dev/null
+++ b/t/recipes/checks/group-checks/group-checks-file-conflict/eval/desc
@@ -0,0 +1,2 @@
+Testname: group-checks-file-conflict
+Check: group-checks
diff --git a/t/recipes/checks/group-checks/group-checks-file-conflict/eval/hints b/t/recipes/checks/group-checks/group-checks-file-conflict/eval/hints
new file mode 100644
index 0000000..e405cca
--- /dev/null
+++ b/t/recipes/checks/group-checks/group-checks-file-conflict/eval/hints
@@ -0,0 +1 @@
+group-checks-file-conflict (source): binaries-have-file-conflict pkga pkgb usr/share/pkga/data-file