summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/images/files-foo-in-bar/build-spec/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/checks/images/files-foo-in-bar/build-spec/debian/rules')
-rwxr-xr-xt/recipes/checks/images/files-foo-in-bar/build-spec/debian/rules18
1 files changed, 18 insertions, 0 deletions
diff --git a/t/recipes/checks/images/files-foo-in-bar/build-spec/debian/rules b/t/recipes/checks/images/files-foo-in-bar/build-spec/debian/rules
new file mode 100755
index 0000000..69a61df
--- /dev/null
+++ b/t/recipes/checks/images/files-foo-in-bar/build-spec/debian/rules
@@ -0,0 +1,18 @@
+#!/usr/bin/make -f
+%:
+ dh $@
+
+override_dh_auto_build:
+ pod2man --section 1 bar.pod > bar.1
+ gzip -n --best bar.1
+ cp bar Bar.pm
+ cp bar bar.png
+ cp bar perllocal.pod
+ touch .packlist
+ touch preferences
+
+override_dh_auto_install:
+ dh_install bar.1.gz usr/X11R6/man/man1/
+
+# skip
+override_dh_usrlocal override_dh_gconf: