summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/languages/python/python-valid-poetry/build-spec/orig/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/checks/languages/python/python-valid-poetry/build-spec/orig/pyproject.toml')
-rw-r--r--t/recipes/checks/languages/python/python-valid-poetry/build-spec/orig/pyproject.toml17
1 files changed, 17 insertions, 0 deletions
diff --git a/t/recipes/checks/languages/python/python-valid-poetry/build-spec/orig/pyproject.toml b/t/recipes/checks/languages/python/python-valid-poetry/build-spec/orig/pyproject.toml
new file mode 100644
index 0000000..cb6ebaa
--- /dev/null
+++ b/t/recipes/checks/languages/python/python-valid-poetry/build-spec/orig/pyproject.toml
@@ -0,0 +1,17 @@
+[build-system]
+requires = ["poetry>=0.12"]
+build-backend = "poetry.core.masonry.api"
+
+[tool.poetry]
+name = "foo"
+description = "an example module"
+version = "0.1"
+authors = ["Stefano Rivera <stefanor@debian.org>"]
+license = "Expat"
+
+[tool.poetry.dependencies]
+tomli = "^1.0.0"
+importlib-metadata = { version="*", python = "<3.5" }
+
+[tool.poetry.scripts]
+foo = 'foo:main'