summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/languages/python/python-wrong-poetry
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/checks/languages/python/python-wrong-poetry')
-rw-r--r--t/recipes/checks/languages/python/python-wrong-poetry/build-spec/debian/control.in19
-rw-r--r--t/recipes/checks/languages/python/python-wrong-poetry/build-spec/fill-values4
-rw-r--r--t/recipes/checks/languages/python/python-wrong-poetry/build-spec/orig/pyproject.toml17
-rw-r--r--t/recipes/checks/languages/python/python-wrong-poetry/eval/desc2
-rw-r--r--t/recipes/checks/languages/python/python-wrong-poetry/eval/hints1
5 files changed, 43 insertions, 0 deletions
diff --git a/t/recipes/checks/languages/python/python-wrong-poetry/build-spec/debian/control.in b/t/recipes/checks/languages/python/python-wrong-poetry/build-spec/debian/control.in
new file mode 100644
index 0000000..3084d99
--- /dev/null
+++ b/t/recipes/checks/languages/python/python-wrong-poetry/build-spec/debian/control.in
@@ -0,0 +1,19 @@
+Source: [% $source %]
+Priority: optional
+Section: python
+Maintainer: [% $author %]
+Standards-Version: [% $standards_version %]
+Build-Depends: [% $build_depends %], python3-poetry, pybuild-plugin-pyproject
+Build-Depends-Indep: python3-poetry-core
+Rules-Requires-Root: no
+
+Package: python3-[% $source %]
+Architecture: all
+Depends: ${misc:Depends}, python3
+Description: Test package (Python 3)
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package. It may
+ be an empty package.
+ .
+ Python 3 variant.
diff --git a/t/recipes/checks/languages/python/python-wrong-poetry/build-spec/fill-values b/t/recipes/checks/languages/python/python-wrong-poetry/build-spec/fill-values
new file mode 100644
index 0000000..135776b
--- /dev/null
+++ b/t/recipes/checks/languages/python/python-wrong-poetry/build-spec/fill-values
@@ -0,0 +1,4 @@
+Skeleton: source-native
+Testname: python-wrong-poetry
+Description: Check packages that build-depend on python3-poetry. Also acts as a
+ test for packages that have the pyproject dependencies in Build-Depends-Indep.
diff --git a/t/recipes/checks/languages/python/python-wrong-poetry/build-spec/orig/pyproject.toml b/t/recipes/checks/languages/python/python-wrong-poetry/build-spec/orig/pyproject.toml
new file mode 100644
index 0000000..cb6ebaa
--- /dev/null
+++ b/t/recipes/checks/languages/python/python-wrong-poetry/build-spec/orig/pyproject.toml
@@ -0,0 +1,17 @@
+[build-system]
+requires = ["poetry>=0.12"]
+build-backend = "poetry.core.masonry.api"
+
+[tool.poetry]
+name = "foo"
+description = "an example module"
+version = "0.1"
+authors = ["Stefano Rivera <stefanor@debian.org>"]
+license = "Expat"
+
+[tool.poetry.dependencies]
+tomli = "^1.0.0"
+importlib-metadata = { version="*", python = "<3.5" }
+
+[tool.poetry.scripts]
+foo = 'foo:main'
diff --git a/t/recipes/checks/languages/python/python-wrong-poetry/eval/desc b/t/recipes/checks/languages/python/python-wrong-poetry/eval/desc
new file mode 100644
index 0000000..f0b7ac1
--- /dev/null
+++ b/t/recipes/checks/languages/python/python-wrong-poetry/eval/desc
@@ -0,0 +1,2 @@
+Testname: python-wrong-poetry
+Check: languages/python
diff --git a/t/recipes/checks/languages/python/python-wrong-poetry/eval/hints b/t/recipes/checks/languages/python/python-wrong-poetry/eval/hints
new file mode 100644
index 0000000..235932a
--- /dev/null
+++ b/t/recipes/checks/languages/python/python-wrong-poetry/eval/hints
@@ -0,0 +1 @@
+python-wrong-poetry (source): uses-poetry-cli [pyproject.toml:3]