summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/languages/python/scripts
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/checks/languages/python/scripts')
-rw-r--r--t/recipes/checks/languages/python/scripts/python-script-uses-unversioned-python-in-shebang/build-spec/debian/control.in16
-rw-r--r--t/recipes/checks/languages/python/scripts/python-script-uses-unversioned-python-in-shebang/build-spec/debian/install1
-rwxr-xr-xt/recipes/checks/languages/python/scripts/python-script-uses-unversioned-python-in-shebang/build-spec/debian/rules4
-rw-r--r--t/recipes/checks/languages/python/scripts/python-script-uses-unversioned-python-in-shebang/build-spec/debian/script-bad11
-rw-r--r--t/recipes/checks/languages/python/scripts/python-script-uses-unversioned-python-in-shebang/build-spec/debian/script-bad21
-rw-r--r--t/recipes/checks/languages/python/scripts/python-script-uses-unversioned-python-in-shebang/build-spec/debian/script-good11
-rw-r--r--t/recipes/checks/languages/python/scripts/python-script-uses-unversioned-python-in-shebang/build-spec/debian/script-good21
-rw-r--r--t/recipes/checks/languages/python/scripts/python-script-uses-unversioned-python-in-shebang/build-spec/fill-values3
-rw-r--r--t/recipes/checks/languages/python/scripts/python-script-uses-unversioned-python-in-shebang/eval/desc2
-rw-r--r--t/recipes/checks/languages/python/scripts/python-script-uses-unversioned-python-in-shebang/eval/hints2
10 files changed, 32 insertions, 0 deletions
diff --git a/t/recipes/checks/languages/python/scripts/python-script-uses-unversioned-python-in-shebang/build-spec/debian/control.in b/t/recipes/checks/languages/python/scripts/python-script-uses-unversioned-python-in-shebang/build-spec/debian/control.in
new file mode 100644
index 0000000..8c005aa
--- /dev/null
+++ b/t/recipes/checks/languages/python/scripts/python-script-uses-unversioned-python-in-shebang/build-spec/debian/control.in
@@ -0,0 +1,16 @@
+Source: [% $source %]
+Priority: optional
+Section: mail
+Maintainer: [% $author %]
+Standards-Version: [% $standards_version %]
+Build-Depends: [% $build_depends %]
+Rules-Requires-Root: no
+
+Package: prog-[% $source %]
+Architecture: [% $package_architecture %]
+Depends: ${misc:Depends}, ${python3:Depends}
+Description: Package with Python script with bad shebang
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package. It may
+ be an empty package.
diff --git a/t/recipes/checks/languages/python/scripts/python-script-uses-unversioned-python-in-shebang/build-spec/debian/install b/t/recipes/checks/languages/python/scripts/python-script-uses-unversioned-python-in-shebang/build-spec/debian/install
new file mode 100644
index 0000000..05e2b78
--- /dev/null
+++ b/t/recipes/checks/languages/python/scripts/python-script-uses-unversioned-python-in-shebang/build-spec/debian/install
@@ -0,0 +1 @@
+debian/script-* /usr/bin
diff --git a/t/recipes/checks/languages/python/scripts/python-script-uses-unversioned-python-in-shebang/build-spec/debian/rules b/t/recipes/checks/languages/python/scripts/python-script-uses-unversioned-python-in-shebang/build-spec/debian/rules
new file mode 100755
index 0000000..2d33f6a
--- /dev/null
+++ b/t/recipes/checks/languages/python/scripts/python-script-uses-unversioned-python-in-shebang/build-spec/debian/rules
@@ -0,0 +1,4 @@
+#!/usr/bin/make -f
+
+%:
+ dh $@
diff --git a/t/recipes/checks/languages/python/scripts/python-script-uses-unversioned-python-in-shebang/build-spec/debian/script-bad1 b/t/recipes/checks/languages/python/scripts/python-script-uses-unversioned-python-in-shebang/build-spec/debian/script-bad1
new file mode 100644
index 0000000..013e4b7
--- /dev/null
+++ b/t/recipes/checks/languages/python/scripts/python-script-uses-unversioned-python-in-shebang/build-spec/debian/script-bad1
@@ -0,0 +1 @@
+#!/usr/bin/python
diff --git a/t/recipes/checks/languages/python/scripts/python-script-uses-unversioned-python-in-shebang/build-spec/debian/script-bad2 b/t/recipes/checks/languages/python/scripts/python-script-uses-unversioned-python-in-shebang/build-spec/debian/script-bad2
new file mode 100644
index 0000000..ee3ecd2
--- /dev/null
+++ b/t/recipes/checks/languages/python/scripts/python-script-uses-unversioned-python-in-shebang/build-spec/debian/script-bad2
@@ -0,0 +1 @@
+#! /usr/bin/env python
diff --git a/t/recipes/checks/languages/python/scripts/python-script-uses-unversioned-python-in-shebang/build-spec/debian/script-good1 b/t/recipes/checks/languages/python/scripts/python-script-uses-unversioned-python-in-shebang/build-spec/debian/script-good1
new file mode 100644
index 0000000..e5a0d9b
--- /dev/null
+++ b/t/recipes/checks/languages/python/scripts/python-script-uses-unversioned-python-in-shebang/build-spec/debian/script-good1
@@ -0,0 +1 @@
+#!/usr/bin/env python3
diff --git a/t/recipes/checks/languages/python/scripts/python-script-uses-unversioned-python-in-shebang/build-spec/debian/script-good2 b/t/recipes/checks/languages/python/scripts/python-script-uses-unversioned-python-in-shebang/build-spec/debian/script-good2
new file mode 100644
index 0000000..a93a4bf
--- /dev/null
+++ b/t/recipes/checks/languages/python/scripts/python-script-uses-unversioned-python-in-shebang/build-spec/debian/script-good2
@@ -0,0 +1 @@
+#!/usr/bin/python3
diff --git a/t/recipes/checks/languages/python/scripts/python-script-uses-unversioned-python-in-shebang/build-spec/fill-values b/t/recipes/checks/languages/python/scripts/python-script-uses-unversioned-python-in-shebang/build-spec/fill-values
new file mode 100644
index 0000000..20ac55b
--- /dev/null
+++ b/t/recipes/checks/languages/python/scripts/python-script-uses-unversioned-python-in-shebang/build-spec/fill-values
@@ -0,0 +1,3 @@
+Skeleton: upload-native
+Testname: python-script-uses-unversioned-python-in-shebang
+Description: Check for unversioned python in shebang
diff --git a/t/recipes/checks/languages/python/scripts/python-script-uses-unversioned-python-in-shebang/eval/desc b/t/recipes/checks/languages/python/scripts/python-script-uses-unversioned-python-in-shebang/eval/desc
new file mode 100644
index 0000000..e2c3be3
--- /dev/null
+++ b/t/recipes/checks/languages/python/scripts/python-script-uses-unversioned-python-in-shebang/eval/desc
@@ -0,0 +1,2 @@
+Testname: python-script-uses-unversioned-python-in-shebang
+Check: languages/python/scripts
diff --git a/t/recipes/checks/languages/python/scripts/python-script-uses-unversioned-python-in-shebang/eval/hints b/t/recipes/checks/languages/python/scripts/python-script-uses-unversioned-python-in-shebang/eval/hints
new file mode 100644
index 0000000..15ce9d3
--- /dev/null
+++ b/t/recipes/checks/languages/python/scripts/python-script-uses-unversioned-python-in-shebang/eval/hints
@@ -0,0 +1,2 @@
+prog-python-script-uses-unversioned-python-in-shebang (binary): script-uses-unversioned-python-in-shebang [usr/bin/script-bad2]
+prog-python-script-uses-unversioned-python-in-shebang (binary): script-uses-unversioned-python-in-shebang [usr/bin/script-bad1]