summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/systemd/no-systemd-service-for-init-script/build-spec/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/checks/systemd/no-systemd-service-for-init-script/build-spec/debian/rules')
-rwxr-xr-xt/recipes/checks/systemd/no-systemd-service-for-init-script/build-spec/debian/rules17
1 files changed, 17 insertions, 0 deletions
diff --git a/t/recipes/checks/systemd/no-systemd-service-for-init-script/build-spec/debian/rules b/t/recipes/checks/systemd/no-systemd-service-for-init-script/build-spec/debian/rules
new file mode 100755
index 0000000..d49d149
--- /dev/null
+++ b/t/recipes/checks/systemd/no-systemd-service-for-init-script/build-spec/debian/rules
@@ -0,0 +1,17 @@
+#!/usr/bin/make -f
+
+export DEB_BUILD_MAINT_OPTIONS=hardening=+all
+
+%:
+ dh $@
+
+override_dh_installinit:
+ dh_installinit
+ dh_installinit --name=other
+
+# In Ubuntu, dh does not catch this file by default.
+# They have diffed it to reduce the size of packages.
+ifneq (,$(strip $(wildcard Changes)))
+override_dh_installchangelogs:
+ dh_installchangelogs Changes
+endif