summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/systemd/no-systemd-timer-for-cron-script
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/checks/systemd/no-systemd-timer-for-cron-script')
-rwxr-xr-xt/recipes/checks/systemd/no-systemd-timer-for-cron-script/build-spec/debian/rules10
-rw-r--r--t/recipes/checks/systemd/no-systemd-timer-for-cron-script/build-spec/fill-values3
-rw-r--r--t/recipes/checks/systemd/no-systemd-timer-for-cron-script/eval/desc2
-rw-r--r--t/recipes/checks/systemd/no-systemd-timer-for-cron-script/eval/hints4
4 files changed, 19 insertions, 0 deletions
diff --git a/t/recipes/checks/systemd/no-systemd-timer-for-cron-script/build-spec/debian/rules b/t/recipes/checks/systemd/no-systemd-timer-for-cron-script/build-spec/debian/rules
new file mode 100755
index 0000000..7e0203d
--- /dev/null
+++ b/t/recipes/checks/systemd/no-systemd-timer-for-cron-script/build-spec/debian/rules
@@ -0,0 +1,10 @@
+#!/usr/bin/make -f
+
+%:
+ dh $@
+
+override_dh_installcron:
+ set -e; for X in daily weekly monthly hourly; do \
+ echo "#!/bin/sh\n\nexit 0" > debian/$(shell dh_listpackages).cron.$$X; \
+ done
+ dh_installcron
diff --git a/t/recipes/checks/systemd/no-systemd-timer-for-cron-script/build-spec/fill-values b/t/recipes/checks/systemd/no-systemd-timer-for-cron-script/build-spec/fill-values
new file mode 100644
index 0000000..0d73f04
--- /dev/null
+++ b/t/recipes/checks/systemd/no-systemd-timer-for-cron-script/build-spec/fill-values
@@ -0,0 +1,3 @@
+Testname: no-systemd-timer-for-cron-script
+Skeleton: upload-native
+Description: Test package with cron scripts but no systemd timer file
diff --git a/t/recipes/checks/systemd/no-systemd-timer-for-cron-script/eval/desc b/t/recipes/checks/systemd/no-systemd-timer-for-cron-script/eval/desc
new file mode 100644
index 0000000..b720e7f
--- /dev/null
+++ b/t/recipes/checks/systemd/no-systemd-timer-for-cron-script/eval/desc
@@ -0,0 +1,2 @@
+Testname: no-systemd-timer-for-cron-script
+Check: systemd
diff --git a/t/recipes/checks/systemd/no-systemd-timer-for-cron-script/eval/hints b/t/recipes/checks/systemd/no-systemd-timer-for-cron-script/eval/hints
new file mode 100644
index 0000000..db8c71b
--- /dev/null
+++ b/t/recipes/checks/systemd/no-systemd-timer-for-cron-script/eval/hints
@@ -0,0 +1,4 @@
+no-systemd-timer-for-cron-script (binary): missing-systemd-timer-for-cron-script [etc/cron.weekly/no-systemd-timer-for-cron-script]
+no-systemd-timer-for-cron-script (binary): missing-systemd-timer-for-cron-script [etc/cron.monthly/no-systemd-timer-for-cron-script]
+no-systemd-timer-for-cron-script (binary): missing-systemd-timer-for-cron-script [etc/cron.hourly/no-systemd-timer-for-cron-script]
+no-systemd-timer-for-cron-script (binary): missing-systemd-timer-for-cron-script [etc/cron.daily/no-systemd-timer-for-cron-script]