summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/systemd/systemd-service-file-refers-to-var-run/build-spec
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/checks/systemd/systemd-service-file-refers-to-var-run/build-spec')
-rw-r--r--t/recipes/checks/systemd/systemd-service-file-refers-to-var-run/build-spec/debian/control.in27
-rw-r--r--t/recipes/checks/systemd/systemd-service-file-refers-to-var-run/build-spec/debian/systemd-service-file-refers-to-var-run-bad.service10
-rw-r--r--t/recipes/checks/systemd/systemd-service-file-refers-to-var-run/build-spec/debian/systemd-service-file-refers-to-var-run-good.service10
-rw-r--r--t/recipes/checks/systemd/systemd-service-file-refers-to-var-run/build-spec/fill-values3
4 files changed, 50 insertions, 0 deletions
diff --git a/t/recipes/checks/systemd/systemd-service-file-refers-to-var-run/build-spec/debian/control.in b/t/recipes/checks/systemd/systemd-service-file-refers-to-var-run/build-spec/debian/control.in
new file mode 100644
index 0000000..d42ecbb
--- /dev/null
+++ b/t/recipes/checks/systemd/systemd-service-file-refers-to-var-run/build-spec/debian/control.in
@@ -0,0 +1,27 @@
+Source: [% $source %]
+Priority: optional
+Section: misc
+Maintainer: [% $author %]
+Standards-Version: [% $standards_version %]
+Build-Depends: [% $build_depends %]
+Rules-Requires-Root: no
+
+Package: [% $source %]-good
+Architecture: all
+Depends: ${misc:Depends}
+Description: [% $description %] (good)
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package.
+ .
+ Good case.
+
+Package: [% $source %]-bad
+Architecture: all
+Depends: ${misc:Depends}
+Description: [% $description %] (bad)
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package.
+ .
+ Bad case.
diff --git a/t/recipes/checks/systemd/systemd-service-file-refers-to-var-run/build-spec/debian/systemd-service-file-refers-to-var-run-bad.service b/t/recipes/checks/systemd/systemd-service-file-refers-to-var-run/build-spec/debian/systemd-service-file-refers-to-var-run-bad.service
new file mode 100644
index 0000000..9ee687e
--- /dev/null
+++ b/t/recipes/checks/systemd/systemd-service-file-refers-to-var-run/build-spec/debian/systemd-service-file-refers-to-var-run-bad.service
@@ -0,0 +1,10 @@
+[Unit]
+After=network.target
+Documentation=https://example.com/
+
+[Service]
+ExecStart=/bin/test
+PIDFile=/run/$NAME.pid
+
+[Install]
+WantedBy=multi-user.target
diff --git a/t/recipes/checks/systemd/systemd-service-file-refers-to-var-run/build-spec/debian/systemd-service-file-refers-to-var-run-good.service b/t/recipes/checks/systemd/systemd-service-file-refers-to-var-run/build-spec/debian/systemd-service-file-refers-to-var-run-good.service
new file mode 100644
index 0000000..b1eda4a
--- /dev/null
+++ b/t/recipes/checks/systemd/systemd-service-file-refers-to-var-run/build-spec/debian/systemd-service-file-refers-to-var-run-good.service
@@ -0,0 +1,10 @@
+[Unit]
+After=network.target
+Documentation=https://example.com/
+
+[Service]
+ExecStart=/bin/test
+PIDFile=/var/run/$NAME.pid
+
+[Install]
+WantedBy=multi-user.target
diff --git a/t/recipes/checks/systemd/systemd-service-file-refers-to-var-run/build-spec/fill-values b/t/recipes/checks/systemd/systemd-service-file-refers-to-var-run/build-spec/fill-values
new file mode 100644
index 0000000..fb822d7
--- /dev/null
+++ b/t/recipes/checks/systemd/systemd-service-file-refers-to-var-run/build-spec/fill-values
@@ -0,0 +1,3 @@
+Skeleton: upload-native
+Testname: systemd-service-file-refers-to-var-run
+Description: Check for PIDFile=/var/run/foo