summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/testsuite/does-not-query-declared-python-versions/build-spec
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/checks/testsuite/does-not-query-declared-python-versions/build-spec')
-rw-r--r--t/recipes/checks/testsuite/does-not-query-declared-python-versions/build-spec/debian/control.in20
-rw-r--r--t/recipes/checks/testsuite/does-not-query-declared-python-versions/build-spec/debian/tests/control2
-rw-r--r--t/recipes/checks/testsuite/does-not-query-declared-python-versions/build-spec/debian/tests/script14
-rw-r--r--t/recipes/checks/testsuite/does-not-query-declared-python-versions/build-spec/fill-values3
4 files changed, 39 insertions, 0 deletions
diff --git a/t/recipes/checks/testsuite/does-not-query-declared-python-versions/build-spec/debian/control.in b/t/recipes/checks/testsuite/does-not-query-declared-python-versions/build-spec/debian/control.in
new file mode 100644
index 0000000..6d6a7c3
--- /dev/null
+++ b/t/recipes/checks/testsuite/does-not-query-declared-python-versions/build-spec/debian/control.in
@@ -0,0 +1,20 @@
+Source: [% $source %]
+Priority: [% $priority %]
+Section: [% $section %]
+Maintainer: [% $author %]
+Standards-Version: [% $standards_version %]
+Build-Depends: [% $build_depends %]
+Rules-Requires-Root: [% $rules_requires_root %]
+Homepage: [% $homepage %]
+X-Python3-Version: >= 3.4
+
+Package: [% $source %]
+Architecture: [% $package_architecture %]
+Pre-Depends: ${misc:Pre-Depends}
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: [% $description %]
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package.
+ .
+ This package probably has no meaningful contents.
diff --git a/t/recipes/checks/testsuite/does-not-query-declared-python-versions/build-spec/debian/tests/control b/t/recipes/checks/testsuite/does-not-query-declared-python-versions/build-spec/debian/tests/control
new file mode 100644
index 0000000..d6ccd9d
--- /dev/null
+++ b/t/recipes/checks/testsuite/does-not-query-declared-python-versions/build-spec/debian/tests/control
@@ -0,0 +1,2 @@
+Tests: script
+Depends: python3-all
diff --git a/t/recipes/checks/testsuite/does-not-query-declared-python-versions/build-spec/debian/tests/script b/t/recipes/checks/testsuite/does-not-query-declared-python-versions/build-spec/debian/tests/script
new file mode 100644
index 0000000..4a0ba92
--- /dev/null
+++ b/t/recipes/checks/testsuite/does-not-query-declared-python-versions/build-spec/debian/tests/script
@@ -0,0 +1,14 @@
+#!/bin/sh
+
+# Good
+echo $(py3versions -r)
+echo $(py3versions -vr)
+echo $(py3versions --requested)
+echo $(py3versions --verbose --requested)
+
+# Bad
+echo $(py3versions -s)
+echo $(py3versions -vs)
+echo $(py3versions --supported)
+echo $(py3versions --verbose --supported)
+
diff --git a/t/recipes/checks/testsuite/does-not-query-declared-python-versions/build-spec/fill-values b/t/recipes/checks/testsuite/does-not-query-declared-python-versions/build-spec/fill-values
new file mode 100644
index 0000000..61308e5
--- /dev/null
+++ b/t/recipes/checks/testsuite/does-not-query-declared-python-versions/build-spec/fill-values
@@ -0,0 +1,3 @@
+Skeleton: source-native
+Testname: does-not-query-declared-python-versions
+Description: Tests for py3versions -s with X-Python3-Version