summaryrefslogtreecommitdiffstats
path: root/t/recipes/tracking/generic-dh-make-2005/build-spec/debian
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/tracking/generic-dh-make-2005/build-spec/debian')
-rw-r--r--t/recipes/tracking/generic-dh-make-2005/build-spec/debian/README.Debian6
-rw-r--r--t/recipes/tracking/generic-dh-make-2005/build-spec/debian/changelog.in6
-rw-r--r--t/recipes/tracking/generic-dh-make-2005/build-spec/debian/compat.in1
-rw-r--r--t/recipes/tracking/generic-dh-make-2005/build-spec/debian/control.in12
-rw-r--r--t/recipes/tracking/generic-dh-make-2005/build-spec/debian/copyright10
-rwxr-xr-xt/recipes/tracking/generic-dh-make-2005/build-spec/debian/rules100
6 files changed, 135 insertions, 0 deletions
diff --git a/t/recipes/tracking/generic-dh-make-2005/build-spec/debian/README.Debian b/t/recipes/tracking/generic-dh-make-2005/build-spec/debian/README.Debian
new file mode 100644
index 0000000..5ce4495
--- /dev/null
+++ b/t/recipes/tracking/generic-dh-make-2005/build-spec/debian/README.Debian
@@ -0,0 +1,6 @@
+dh-test for Debian
+------------------
+
+<possible notes regarding this package - if none, delete this file>
+
+ -- Frank Lichtenheld <djpig@debian.org>, Thu, 4 Aug 2005 23:09:00 +0200
diff --git a/t/recipes/tracking/generic-dh-make-2005/build-spec/debian/changelog.in b/t/recipes/tracking/generic-dh-make-2005/build-spec/debian/changelog.in
new file mode 100644
index 0000000..580f946
--- /dev/null
+++ b/t/recipes/tracking/generic-dh-make-2005/build-spec/debian/changelog.in
@@ -0,0 +1,6 @@
+generic-dh-make-2005 ([% $version %]) [% $distribution %]; urgency=low
+
+ * Initial release Closes: #nnnn (nnnn is the bug number of your ITP)
+
+ -- Frank Lichtenheld <djpig@debian.org> Thu, 4 Aug 2005 23:09:00 +0200
+
diff --git a/t/recipes/tracking/generic-dh-make-2005/build-spec/debian/compat.in b/t/recipes/tracking/generic-dh-make-2005/build-spec/debian/compat.in
new file mode 100644
index 0000000..640a566
--- /dev/null
+++ b/t/recipes/tracking/generic-dh-make-2005/build-spec/debian/compat.in
@@ -0,0 +1 @@
+[% $dh_compat_level %]
diff --git a/t/recipes/tracking/generic-dh-make-2005/build-spec/debian/control.in b/t/recipes/tracking/generic-dh-make-2005/build-spec/debian/control.in
new file mode 100644
index 0000000..4cbbc4e
--- /dev/null
+++ b/t/recipes/tracking/generic-dh-make-2005/build-spec/debian/control.in
@@ -0,0 +1,12 @@
+Source: generic-dh-make-2005
+Section: unknown
+Priority: optional
+Maintainer: Frank Lichtenheld <djpig@debian.org>
+Build-Depends: debhelper (>= 4.0.0)
+Standards-Version: 3.6.2
+
+Package: generic-dh-make-2005
+Architecture: [% $package_architecture %]
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: <insert up to 60 chars description>
+ <insert long description, indented with spaces>
diff --git a/t/recipes/tracking/generic-dh-make-2005/build-spec/debian/copyright b/t/recipes/tracking/generic-dh-make-2005/build-spec/debian/copyright
new file mode 100644
index 0000000..2bcce49
--- /dev/null
+++ b/t/recipes/tracking/generic-dh-make-2005/build-spec/debian/copyright
@@ -0,0 +1,10 @@
+This package was debianized by Frank Lichtenheld <djpig@debian.org> on
+Thu, 4 Aug 2005 23:09:00 +0200.
+
+It was downloaded from <fill in ftp site>
+
+Copyright Holder: <put author(s) name and email here>
+
+License:
+
+<Put the license of the package here>
diff --git a/t/recipes/tracking/generic-dh-make-2005/build-spec/debian/rules b/t/recipes/tracking/generic-dh-make-2005/build-spec/debian/rules
new file mode 100755
index 0000000..ee4bffb
--- /dev/null
+++ b/t/recipes/tracking/generic-dh-make-2005/build-spec/debian/rules
@@ -0,0 +1,100 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+
+
+CFLAGS = -Wall -g
+
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ CFLAGS += -O0
+else
+ CFLAGS += -O2
+endif
+
+configure: configure-stamp
+configure-stamp:
+ dh_testdir
+ # Add here commands to configure the package.
+
+ touch configure-stamp
+
+
+build: build-stamp
+
+build-stamp: configure-stamp
+ dh_testdir
+
+ # Add here commands to compile the package.
+# $(MAKE)
+ #docbook-to-man debian/dh-test.sgml > dh-test.1
+
+ touch build-stamp
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
+
+ # Add here commands to clean up after the build process.
+ -$(MAKE) clean
+
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ # Add here commands to install the package into debian/dh-test.
+# $(MAKE) install DESTDIR=$(CURDIR)/debian/dh-test
+
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+# dh_testversion
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_installexamples
+# dh_install
+# dh_installmenu
+# dh_installdebconf
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+# dh_installinit
+# dh_installcron
+# dh_installinfo
+ dh_installman
+# dh_dhelp
+ #dh_suidregister # originally there, but no longer supported
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+# dh_perl
+# dh_python
+# dh_makeshlibs
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure