summaryrefslogtreecommitdiffstats
path: root/t/recipes/tracking/generic-dh-make-2005
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/tracking/generic-dh-make-2005')
-rw-r--r--t/recipes/tracking/generic-dh-make-2005/build-spec/debian/README.Debian6
-rw-r--r--t/recipes/tracking/generic-dh-make-2005/build-spec/debian/changelog.in6
-rw-r--r--t/recipes/tracking/generic-dh-make-2005/build-spec/debian/compat.in1
-rw-r--r--t/recipes/tracking/generic-dh-make-2005/build-spec/debian/control.in12
-rw-r--r--t/recipes/tracking/generic-dh-make-2005/build-spec/debian/copyright10
-rwxr-xr-xt/recipes/tracking/generic-dh-make-2005/build-spec/debian/rules100
-rw-r--r--t/recipes/tracking/generic-dh-make-2005/build-spec/fill-values8
-rw-r--r--t/recipes/tracking/generic-dh-make-2005/build-spec/orig/README9
-rwxr-xr-xt/recipes/tracking/generic-dh-make-2005/build-spec/pre-build.in5
-rw-r--r--t/recipes/tracking/generic-dh-make-2005/eval/desc2
-rw-r--r--t/recipes/tracking/generic-dh-make-2005/eval/hints31
-rw-r--r--t/recipes/tracking/generic-dh-make-2005/eval/post-test1
12 files changed, 191 insertions, 0 deletions
diff --git a/t/recipes/tracking/generic-dh-make-2005/build-spec/debian/README.Debian b/t/recipes/tracking/generic-dh-make-2005/build-spec/debian/README.Debian
new file mode 100644
index 0000000..5ce4495
--- /dev/null
+++ b/t/recipes/tracking/generic-dh-make-2005/build-spec/debian/README.Debian
@@ -0,0 +1,6 @@
+dh-test for Debian
+------------------
+
+<possible notes regarding this package - if none, delete this file>
+
+ -- Frank Lichtenheld <djpig@debian.org>, Thu, 4 Aug 2005 23:09:00 +0200
diff --git a/t/recipes/tracking/generic-dh-make-2005/build-spec/debian/changelog.in b/t/recipes/tracking/generic-dh-make-2005/build-spec/debian/changelog.in
new file mode 100644
index 0000000..580f946
--- /dev/null
+++ b/t/recipes/tracking/generic-dh-make-2005/build-spec/debian/changelog.in
@@ -0,0 +1,6 @@
+generic-dh-make-2005 ([% $version %]) [% $distribution %]; urgency=low
+
+ * Initial release Closes: #nnnn (nnnn is the bug number of your ITP)
+
+ -- Frank Lichtenheld <djpig@debian.org> Thu, 4 Aug 2005 23:09:00 +0200
+
diff --git a/t/recipes/tracking/generic-dh-make-2005/build-spec/debian/compat.in b/t/recipes/tracking/generic-dh-make-2005/build-spec/debian/compat.in
new file mode 100644
index 0000000..640a566
--- /dev/null
+++ b/t/recipes/tracking/generic-dh-make-2005/build-spec/debian/compat.in
@@ -0,0 +1 @@
+[% $dh_compat_level %]
diff --git a/t/recipes/tracking/generic-dh-make-2005/build-spec/debian/control.in b/t/recipes/tracking/generic-dh-make-2005/build-spec/debian/control.in
new file mode 100644
index 0000000..4cbbc4e
--- /dev/null
+++ b/t/recipes/tracking/generic-dh-make-2005/build-spec/debian/control.in
@@ -0,0 +1,12 @@
+Source: generic-dh-make-2005
+Section: unknown
+Priority: optional
+Maintainer: Frank Lichtenheld <djpig@debian.org>
+Build-Depends: debhelper (>= 4.0.0)
+Standards-Version: 3.6.2
+
+Package: generic-dh-make-2005
+Architecture: [% $package_architecture %]
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: <insert up to 60 chars description>
+ <insert long description, indented with spaces>
diff --git a/t/recipes/tracking/generic-dh-make-2005/build-spec/debian/copyright b/t/recipes/tracking/generic-dh-make-2005/build-spec/debian/copyright
new file mode 100644
index 0000000..2bcce49
--- /dev/null
+++ b/t/recipes/tracking/generic-dh-make-2005/build-spec/debian/copyright
@@ -0,0 +1,10 @@
+This package was debianized by Frank Lichtenheld <djpig@debian.org> on
+Thu, 4 Aug 2005 23:09:00 +0200.
+
+It was downloaded from <fill in ftp site>
+
+Copyright Holder: <put author(s) name and email here>
+
+License:
+
+<Put the license of the package here>
diff --git a/t/recipes/tracking/generic-dh-make-2005/build-spec/debian/rules b/t/recipes/tracking/generic-dh-make-2005/build-spec/debian/rules
new file mode 100755
index 0000000..ee4bffb
--- /dev/null
+++ b/t/recipes/tracking/generic-dh-make-2005/build-spec/debian/rules
@@ -0,0 +1,100 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+
+
+CFLAGS = -Wall -g
+
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ CFLAGS += -O0
+else
+ CFLAGS += -O2
+endif
+
+configure: configure-stamp
+configure-stamp:
+ dh_testdir
+ # Add here commands to configure the package.
+
+ touch configure-stamp
+
+
+build: build-stamp
+
+build-stamp: configure-stamp
+ dh_testdir
+
+ # Add here commands to compile the package.
+# $(MAKE)
+ #docbook-to-man debian/dh-test.sgml > dh-test.1
+
+ touch build-stamp
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
+
+ # Add here commands to clean up after the build process.
+ -$(MAKE) clean
+
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ # Add here commands to install the package into debian/dh-test.
+# $(MAKE) install DESTDIR=$(CURDIR)/debian/dh-test
+
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+# dh_testversion
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_installexamples
+# dh_install
+# dh_installmenu
+# dh_installdebconf
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+# dh_installinit
+# dh_installcron
+# dh_installinfo
+ dh_installman
+# dh_dhelp
+ #dh_suidregister # originally there, but no longer supported
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+# dh_perl
+# dh_python
+# dh_makeshlibs
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure
diff --git a/t/recipes/tracking/generic-dh-make-2005/build-spec/fill-values b/t/recipes/tracking/generic-dh-make-2005/build-spec/fill-values
new file mode 100644
index 0000000..01371b6
--- /dev/null
+++ b/t/recipes/tracking/generic-dh-make-2005/build-spec/fill-values
@@ -0,0 +1,8 @@
+Testname: generic-dh-make-2005
+Skeleton: upload-builder-only
+Author: Frank Lichtenheld <djpig@debian.org>
+Version: 1-1
+Package-Architecture: any
+Dh-Compat-Level: 7
+Description: Generic dh_make template generated in 2005
+Default-Build-Depends: debhelper (>= [% $dh_compat_level %]~)
diff --git a/t/recipes/tracking/generic-dh-make-2005/build-spec/orig/README b/t/recipes/tracking/generic-dh-make-2005/build-spec/orig/README
new file mode 100644
index 0000000..e6a5a27
--- /dev/null
+++ b/t/recipes/tracking/generic-dh-make-2005/build-spec/orig/README
@@ -0,0 +1,9 @@
+This is something close to the results of running dh_make on a basically
+empty upstream tarball in 2005, but with the example files removed. It's
+a useful test for the various dh_make template and boilerplate tags, as
+well as many tags for ways of doing things dh_make used to promote but are
+now deprecated or old debhelper commands that are now deprecated.
+
+Please don't modify anything about the files in this package; instead, add
+new tags as needed when Lintian adds new checks. This test case is
+intended to continue to be a test of Lintian's handling of old packages.
diff --git a/t/recipes/tracking/generic-dh-make-2005/build-spec/pre-build.in b/t/recipes/tracking/generic-dh-make-2005/build-spec/pre-build.in
new file mode 100755
index 0000000..bbdb5cb
--- /dev/null
+++ b/t/recipes/tracking/generic-dh-make-2005/build-spec/pre-build.in
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+# not using any templates, but dh_clean requires compat
+
+echo "[% $dh_compat_level %]" > "$1/debian/compat"
diff --git a/t/recipes/tracking/generic-dh-make-2005/eval/desc b/t/recipes/tracking/generic-dh-make-2005/eval/desc
new file mode 100644
index 0000000..2b633dd
--- /dev/null
+++ b/t/recipes/tracking/generic-dh-make-2005/eval/desc
@@ -0,0 +1,2 @@
+Testname: generic-dh-make-2005
+Default-Lintian-Options: --pedantic --display-info --display-experimental
diff --git a/t/recipes/tracking/generic-dh-make-2005/eval/hints b/t/recipes/tracking/generic-dh-make-2005/eval/hints
new file mode 100644
index 0000000..b8ad3c8
--- /dev/null
+++ b/t/recipes/tracking/generic-dh-make-2005/eval/hints
@@ -0,0 +1,31 @@
+generic-dh-make-2005 (source): upstream-metadata-file-is-missing
+generic-dh-make-2005 (source): trailing-whitespace [debian/rules:70]
+generic-dh-make-2005 (source): trailing-whitespace [debian/rules:54]
+generic-dh-make-2005 (source): trailing-whitespace [debian/rules:49]
+generic-dh-make-2005 (source): trailing-whitespace [debian/rules:32]
+generic-dh-make-2005 (source): trailing-whitespace [debian/changelog:6]
+generic-dh-make-2005 (source): silent-on-rules-requiring-root [debian/control]
+generic-dh-make-2005 (source): package-uses-deprecated-debhelper-compat-version 7
+generic-dh-make-2005 (source): older-source-format 1.0
+generic-dh-make-2005 (source): no-versioned-debhelper-prerequisite 7
+generic-dh-make-2005 (source): no-homepage-field
+generic-dh-make-2005 (source): no-dh-sequencer [debian/rules]
+generic-dh-make-2005 (source): no-dep5-copyright [debian/copyright]
+generic-dh-make-2005 (source): missing-debian-source-format
+generic-dh-make-2005 (source): dh-clean-k-is-deprecated [debian/rules]
+generic-dh-make-2005 (source): debian-watch-file-is-missing
+generic-dh-make-2005 (source): debian-rules-should-not-set-CFLAGS-from-noopt [debian/rules]
+generic-dh-make-2005 (source): debian-rules-missing-required-target build-indep [debian/rules]
+generic-dh-make-2005 (source): debian-rules-missing-required-target build-arch [debian/rules]
+generic-dh-make-2005 (source): debian-rules-ignores-make-clean-error [debian/rules:47]
+generic-dh-make-2005 (binary): wrong-bug-number-in-closes #nnnn [usr/share/doc/generic-dh-make-2005/changelog.Debian.gz:3]
+generic-dh-make-2005 (binary): section-is-dh_make-template
+generic-dh-make-2005 (binary): readme-debian-contains-debmake-template [usr/share/doc/generic-dh-make-2005/README.Debian]
+generic-dh-make-2005 (binary): package-contains-no-arch-dependent-files
+generic-dh-make-2005 (binary): initial-upload-closes-no-bugs [usr/share/doc/generic-dh-make-2005/changelog.Debian.gz:1]
+generic-dh-make-2005 (binary): helper-templates-in-copyright
+generic-dh-make-2005 (binary): extended-description-is-probably-too-short
+generic-dh-make-2005 (binary): empty-binary-package
+generic-dh-make-2005 (binary): description-is-dh_make-template
+generic-dh-make-2005 (binary): copyright-without-copyright-notice
+generic-dh-make-2005 (binary): changelog-is-dh_make-template [usr/share/doc/generic-dh-make-2005/changelog.Debian.gz:1]
diff --git a/t/recipes/tracking/generic-dh-make-2005/eval/post-test b/t/recipes/tracking/generic-dh-make-2005/eval/post-test
new file mode 100644
index 0000000..faeef0b
--- /dev/null
+++ b/t/recipes/tracking/generic-dh-make-2005/eval/post-test
@@ -0,0 +1 @@
+s/\(current is ([0-9]+\.)+[0-9]\)/(current is CURRENT)/