summaryrefslogtreecommitdiffstats
path: root/arch/mips/kvm/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-11 08:27:49 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-11 08:27:49 +0000
commitace9429bb58fd418f0c81d4c2835699bddf6bde6 (patch)
treeb2d64bc10158fdd5497876388cd68142ca374ed3 /arch/mips/kvm/Makefile
parentInitial commit. (diff)
downloadlinux-ace9429bb58fd418f0c81d4c2835699bddf6bde6.tar.xz
linux-ace9429bb58fd418f0c81d4c2835699bddf6bde6.zip
Adding upstream version 6.6.15.upstream/6.6.15
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'arch/mips/kvm/Makefile')
-rw-r--r--arch/mips/kvm/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/arch/mips/kvm/Makefile b/arch/mips/kvm/Makefile
new file mode 100644
index 0000000000..805aeea216
--- /dev/null
+++ b/arch/mips/kvm/Makefile
@@ -0,0 +1,20 @@
+# SPDX-License-Identifier: GPL-2.0
+# Makefile for KVM support for MIPS
+#
+
+include $(srctree)/virt/kvm/Makefile.kvm
+
+ccflags-y += -Ivirt/kvm -Iarch/mips/kvm
+
+kvm-$(CONFIG_CPU_HAS_MSA) += msa.o
+
+kvm-y += mips.o emulate.o entry.o \
+ interrupt.o stats.o \
+ fpu.o
+kvm-y += hypcall.o
+kvm-y += mmu.o
+kvm-$(CONFIG_CPU_LOONGSON64) += loongson_ipi.o
+
+kvm-y += vz.o
+obj-$(CONFIG_KVM) += kvm.o
+obj-y += tlb.o