summaryrefslogtreecommitdiffstats
path: root/debian/rules.d/tools/perf
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 17:39:59 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 17:39:59 +0000
commit27d3313807296c3943a96ceef8c2b7279cb56962 (patch)
tree7d08e78c36ab6437b403fc7cd8c23e41f135c7a3 /debian/rules.d/tools/perf
parentMerging upstream version 6.7.7. (diff)
downloadlinux-27d3313807296c3943a96ceef8c2b7279cb56962.tar.xz
linux-27d3313807296c3943a96ceef8c2b7279cb56962.zip
Adding debian version 6.7.7-1.debian/6.7.7-1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules.d/tools/perf')
-rw-r--r--debian/rules.d/tools/perf/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/debian/rules.d/tools/perf/Makefile b/debian/rules.d/tools/perf/Makefile
index 910f03776f..b81116ab17 100644
--- a/debian/rules.d/tools/perf/Makefile
+++ b/debian/rules.d/tools/perf/Makefile
@@ -50,8 +50,12 @@ ifeq (,$(filter nodoc,$(DEB_BUILD_PROFILES)))
+$(MAKE_PERF) -C $(top_srcdir)/tools/perf/Documentation man
endif
# Check that perf didn't get linked against incompatibly-licensed libraries
- type ldd
- ! ldd $(CURDIR)/perf | grep -E '\blib(bfd|crypto|debuginfod)'
+ @if readelf -d $(CURDIR)/perf | sed -rne 's/.*NEEDED.*\[(.*)\]/\1/p' | grep -E '\blib(bfd|crypto|debuginfod)'; then \
+ echo; \
+ echo 'perf linked against incompatibly-licensed libraries'; \
+ echo; \
+ exit 1; \
+ fi
# Check that it links against abi::__cxa_demangle from libstdc++
grep __cxa_demangle $(CURDIR)/perf