summaryrefslogtreecommitdiffstats
path: root/debian/salsa-ci.yml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 17:40:22 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 17:44:43 +0000
commitb5b67adcc17e3e74dbcda09ff3f8a4636aa53486 (patch)
tree601c346183757b42c53b1d0aa8773cb00d1bd73c /debian/salsa-ci.yml
parentMerging upstream version 6.7.7. (diff)
downloadlinux-b5b67adcc17e3e74dbcda09ff3f8a4636aa53486.tar.xz
linux-b5b67adcc17e3e74dbcda09ff3f8a4636aa53486.zip
Merging debian version 6.7.7-1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--debian/salsa-ci.yml5
1 files changed, 3 insertions, 2 deletions
diff --git a/debian/salsa-ci.yml b/debian/salsa-ci.yml
index 3062e82ef9..58efe6a395 100644
--- a/debian/salsa-ci.yml
+++ b/debian/salsa-ci.yml
@@ -60,6 +60,7 @@ extract-source:
gpgv \
kernel-wedge \
python3 \
+ python3-dacite \
python3-debian \
python3-jinja2 \
quilt \
@@ -213,7 +214,7 @@ python-static:
script:
- |
apt-get update && eatmydata apt-get install --no-install-recommends -y \
- flake8 python3 python3-jinja2 python3-pytest
+ flake8 python3 python3-dacite python3-jinja2 python3-pytest
# Run both checkers and coalesce their results rather than exiting
# on first failure
@@ -236,7 +237,7 @@ kconfig-static:
# Unpack source and apply featureset patches
- |
apt-get update && eatmydata apt-get install --no-install-recommends -y \
- debhelper dpkg-dev git python3 quilt
+ debhelper dpkg-dev git python3 python3-dacite quilt
- dpkg-source -x ${WORKING_DIR}/*.dsc ${WORKING_DIR}/${SOURCE_DIR}
- cd ${WORKING_DIR}/${SOURCE_DIR}
- debian/rules source