summaryrefslogtreecommitdiffstats
path: root/arch/arm/mach-mmp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'arch/arm/mach-mmp/Makefile')
-rw-r--r--arch/arm/mach-mmp/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/arch/arm/mach-mmp/Makefile b/arch/arm/mach-mmp/Makefile
new file mode 100644
index 0000000000..5d4a1a4a48
--- /dev/null
+++ b/arch/arm/mach-mmp/Makefile
@@ -0,0 +1,14 @@
+# SPDX-License-Identifier: GPL-2.0
+#
+# Makefile for Marvell's PXA168 processors line
+#
+obj-y += common.o time.o
+
+ifeq ($(CONFIG_SMP),y)
+obj-$(CONFIG_MACH_MMP3_DT) += platsmp.o
+endif
+
+# board support
+obj-$(CONFIG_MACH_MMP_DT) += mmp-dt.o
+obj-$(CONFIG_MACH_MMP2_DT) += mmp2-dt.o
+obj-$(CONFIG_MACH_MMP3_DT) += mmp3.o