summaryrefslogtreecommitdiffstats
path: root/arch/arm/mach-s3c/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'arch/arm/mach-s3c/Makefile')
-rw-r--r--arch/arm/mach-s3c/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/arch/arm/mach-s3c/Makefile b/arch/arm/mach-s3c/Makefile
new file mode 100644
index 0000000000..713827bef8
--- /dev/null
+++ b/arch/arm/mach-s3c/Makefile
@@ -0,0 +1,23 @@
+# SPDX-License-Identifier: GPL-2.0
+#
+# Copyright 2009 Simtec Electronics
+
+include $(srctree)/$(src)/Makefile.s3c64xx
+
+# Objects we always build independent of SoC choice
+
+obj-y += init.o cpu.o
+
+# devices
+
+obj-$(CONFIG_SAMSUNG_ATAGS) += platformdata.o
+obj-$(CONFIG_SAMSUNG_ATAGS) += devs.o
+obj-$(CONFIG_SAMSUNG_ATAGS) += dev-uart.o
+
+obj-$(CONFIG_GPIO_SAMSUNG) += gpio-samsung.o
+
+# PM support
+
+obj-$(CONFIG_SAMSUNG_PM) += pm.o pm-common.o
+obj-$(CONFIG_SAMSUNG_PM_GPIO) += pm-gpio.o
+obj-$(CONFIG_SAMSUNG_WAKEMASK) += wakeup-mask.o