summaryrefslogtreecommitdiffstats
path: root/debian/changelog
diff options
context:
space:
mode:
Diffstat (limited to 'debian/changelog')
-rw-r--r--debian/changelog232
1 files changed, 232 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 252f7639cf..bce2bb3bcd 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,235 @@
+linux (6.9.8-1) unstable; urgency=medium
+
+ * New upstream stable update:
+ https://www.kernel.org/pub/linux/kernel/v6.x/ChangeLog-6.9.8
+ - usb: typec: ucsi: Never send a lone connector change ack
+ - usb: typec: ucsi: Ack also failed Get Error commands
+ - [arm64] pinctrl: renesas: rzg2l: Use spin_{lock,unlock}_irq{save,restore}
+ - Input: ili210x - fix ili251x_read_touch_data() return value
+ - pinctrl: fix deadlock in create_pinctrl() when handling -EPROBE_DEFER
+ - [arm64,armhf] pinctrl: rockchip: fix pinmux bits for RK3328 GPIO2-B pins
+ - [arm64,armhf] pinctrl: rockchip: fix pinmux bits for RK3328 GPIO3-B pins
+ - [arm64,armhf] pinctrl: rockchip: use dedicated pinctrl type for RK3328
+ - [arm64,armhf] pinctrl: rockchip: fix pinmux reset in rockchip_pmx_set
+ - [mips*] pci: lantiq: restore reset gpio polarity
+ - [x86] ASoC: cs42l43: Increase default type detect time and button delay
+ - [arm64] ASoC: rockchip: i2s-tdm: Fix trcm mode by setting clock on right
+ mclk
+ - [arm64] ASoC: mediatek: mt8183-da7219-max98357: Fix kcontrol name
+ collision
+ - workqueue: Increase worker desc's length to 32
+ - [arm64] ASoC: q6apm-lpass-dai: close graph on prepare errors
+ - bpf: Add missed var_off setting in set_sext32_default_val()
+ - bpf: Add missed var_off setting in coerce_subreg_to_size_sx()
+ - [s390x] pci: Add missing virt_to_phys() for directed DIBV
+ - [s390x] virtio_ccw: Fix config change notifications
+ - bpf: Fix remap of arena.
+ - ASoC: amd: acp: add a null check for chip_pdev structure
+ - ASoC: amd: acp: remove i2s configuration check in acp_i2s_probe()
+ - ASoC: amd: acp: move chip->flag variable assignment
+ - ASoC: fsl-asoc-card: set priv->pdev before using it
+ - net: dsa: microchip: fix initial port flush problem
+ - openvswitch: get related ct labels from its master if it is not confirmed
+ - bonding: fix incorrect software timestamping report
+ - ionic: fix kernel panic due to multi-buffer handling
+ - mlxsw: pci: Fix driver initialization with Spectrum-4
+ - mlxsw: spectrum_buffers: Fix memory corruptions on Spectrum-4 systems
+ - bpf: Fix the corner case with may_goto and jump to the 1st insn.
+ - bpf: Fix overrunning reservations in ringbuf
+ - vxlan: Pull inner IP header in vxlan_xmit_one().
+ - ibmvnic: Free any outstanding tx skbs during scrq reset
+ - net: phy: micrel: add Microchip KSZ 9477 to the device table
+ - net: dsa: microchip: use collision based back pressure mode
+ - ice: Rebuild TC queues on VSI queue reconfiguration
+ - bpf: Fix may_goto with negative offset.
+ - xdp: Remove WARN() from __xdp_reg_mem_model()
+ - btrfs: use NOFS context when getting inodes during logging and log replay
+ - Fix race for duplicate reqsk on identical SYN
+ - ALSA: seq: Fix missing channel at encoding RPN/NRPN MIDI2 messages
+ - net: dsa: microchip: fix wrong register write when masking interrupt
+ - [powerpc*] restore some missing spu syscalls
+ - ionic: use dev_consume_skb_any outside of napi
+ - tcp: fix tcp_rcv_fastopen_synack() to enter TCP_CA_Loss for failed TFO
+ - ALSA: seq: Fix missing MSB in MIDI2 SPP conversion
+ - netfilter: nf_tables: fully validate NFT_DATA_VALUE on store to data
+ registers
+ - af_unix: Stop recv(MSG_PEEK) at consumed OOB skb.
+ - af_unix: Don't stop recv(MSG_DONTWAIT) if consumed OOB skb is at the head.
+ - af_unix: Don't stop recv() at consumed ex-OOB skb.
+ - af_unix: Fix wrong ioctl(SIOCATMARK) when consumed OOB skb is at the head.
+ - net: mana: Fix possible double free in error handling path
+ - bpf: Take return from set_memory_ro() into account with bpf_prog_lock_ro()
+ - bpf: Take return from set_memory_rox() into account with
+ bpf_jit_binary_lock_ro()
+ - drm/panel: ilitek-ili9881c: Fix warning with GPIO controllers that sleep
+ - drm/xe: Fix potential integer overflow in page size calculation
+ - vduse: validate block features only with block devices
+ - vduse: Temporarily fail if control queue feature requested
+ - [x86] fpu: Fix AMD X86_BUG_FXSAVE_LEAK fixup
+ - drm/xe: Add a NULL check in xe_ttm_stolen_mgr_init
+ - drm/amd/display: correct hostvm flag
+ - mtd: partitions: redboot: Added conversion of operands to a larger type
+ - wifi: ieee80211: check for NULL in ieee80211_mle_size_ok()
+ - drm/amd/display: Skip pipe if the pipe idx not set properly
+ - bpf: Add a check for struct bpf_fib_lookup size
+ - bpf: Mark bpf prog stack with kmsan_unposion_memory in interpreter mode
+ - drm/xe/xe_devcoredump: Check NULL before assignments
+ - RDMA/restrack: Fix potential invalid address access
+ - net/iucv: Avoid explicit cpumask var allocation on stack
+ - net/dpaa2: Avoid explicit cpumask var allocation on stack
+ - wifi: rtw89: download firmware with five times retry
+ - crypto: ecdh - explicitly zeroize private_key
+ - ALSA: emux: improve patch ioctl data validation
+ - media: dvbdev: Initialize sbuf
+ - irqchip/loongson: Select GENERIC_IRQ_EFFECTIVE_AFF_MASK if SMP for
+ IRQ_LOONGARCH_CPU
+ - iommu/arm-smmu-v3: Do not allow a SVA domain to be set on the wrong PASID
+ - soc: ti: wkup_m3_ipc: Send NULL dummy message instead of pointer message
+ - gfs2: Fix NULL pointer dereference in gfs2_log_flush
+ - evm: Enforce signatures on unsupported filesystem for EVM_INIT_X509
+ - drm/radeon/radeon_display: Decrease the size of allocated memory
+ - drm/xe: Check pat.ops before dumping PAT settings
+ - nvmet: do not return 'reserved' for empty TSAS values
+ - nvme: fixup comment for nvme RDMA Provider Type
+ - nvmet: make 'tsas' attribute idempotent for RDMA
+ - drm/panel: simple: Add missing display timing flags for KOE TX26D202VM0BWA
+ - gpio: davinci: Validate the obtained number of IRQs
+ - arm64: Clear the initial ID map correctly before remapping
+ - nfsd: initialise nfsd_info.mutex early.
+ - [riscv64] fix vector insn load/store width mask
+ - drm/amdgpu: Fix pci state save during mode-1 reset
+ - [riscv64] stacktrace: convert arch_stack_walk() to noinstr
+ - [amd64] iommu/amd: Introduce per device DTE update function
+ - [amd64] iommu/amd: Invalidate cache before removing device from domain
+ list
+ - [amd64] iommu/amd: Fix GT feature enablement again
+ - gpiolib: cdev: Disallow reconfiguration without direction (uAPI v1)
+ - gpiolib: cdev: Ignore reconfiguration without direction
+ - randomize_kstack: Remove non-functional per-arch entropy filtering
+ - [x86] stop playing stack games in profile_pc()
+ - Revert "MIPS: pci: lantiq: restore reset gpio polarity"
+ - pinctrl: qcom: spmi-gpio: drop broken pm8008 support
+ - ocfs2: fix DIO failure due to insufficient transaction credits
+ - nfs: drop the incorrect assertion in nfs_swap_rw()
+ - kasan: fix bad call to unpoison_slab_object
+ - mm: fix incorrect vbq reference in purge_fragmented_block
+ - mm/memory: don't require head page for do_set_pmd()
+ - Revert "mmc: moxart-mmc: Use sg_miter for PIO"
+ - mmc: sdhci-pci-o2micro: Convert PCIBIOS_* return codes to errnos
+ - mmc: sdhci-brcmstb: check R1_STATUS for erase/trim/discard
+ - mmc: sdhci-pci: Convert PCIBIOS_* return codes to errnos
+ - mmc: sdhci: Do not invert write-protect twice
+ - mmc: sdhci: Do not lock spinlock around mmc_gpio_get_ro()
+ - iio: xilinx-ams: Don't include ams_ctrl_channels in scan_mask
+ - SUNRPC: Fix backchannel reply, again
+ - counter: ti-eqep: enable clock at probe
+ - kbuild: doc: Update default INSTALL_MOD_DIR from extra to updates
+ - kbuild: Fix build target deb-pkg: ln: failed to create hard link
+ - kbuild: rpm-pkg: fix build error with CONFIG_MODULES=n
+ - i2c: testunit: don't erase registers after STOP
+ - i2c: testunit: discard write requests while old command is running
+ - ata: libata-core: Fix null pointer dereference on error
+ - ata,scsi: libata-core: Do not leak memory for ata_port struct members
+ - iio: humidity: hdc3020: fix hysteresis representation
+ - iio: adc: ad7266: Fix variable checking bug
+ - iio: accel: fxls8962af: select IIO_BUFFER & IIO_KFIFO_BUF
+ - net: usb: ax88179_178a: improve link status logs
+ - usb: gadget: printer: SS+ support
+ - usb: gadget: printer: fix races against disable
+ - usb: musb: da8xx: fix a resource leak in probe()
+ - usb: atm: cxacru: fix endpoint checking in cxacru_bind()
+ - usb: dwc3: core: remove lock of otg mode during gadget suspend/resume to
+ avoid deadlock
+ - usb: gadget: aspeed_udc: fix device address configuration
+ - usb: typec: ucsi: glink: fix child node release in probe function
+ - Revert "usb: gadget: u_ether: Re-attach netif device to mirror detachment"
+ - Revert "usb: gadget: u_ether: Replace netif_stop_queue with
+ netif_device_detach"
+ - usb: ucsi: stm32: fix command completion handling
+ - usb: dwc3: core: Workaround for CSR read timeout
+ - Revert "serial: core: only stop transmit when HW fifo is empty"
+ - tty: serial: 8250: Fix port count mismatch with the device
+ - serial: 8250_omap: Implementation of Errata i2310
+ - serial: imx: set receiver level before starting uart
+ - serial: core: introduce uart_port_tx_limited_flags()
+ - serial: bcm63xx-uart: fix tx after conversion to uart_port_tx_limited()
+ - ALSA: hda/realtek: fix mute/micmute LEDs don't work for EliteBook 645/665
+ G11.
+ - tty: mxser: Remove __counted_by from mxser_board.ports[]
+ - tty: mcf: MCF54418 has 10 UARTS
+ - net: can: j1939: Initialize unused data in j1939_send_one()
+ - net: can: j1939: recover socket queue on CAN bus error during BAM
+ transmission
+ - net: can: j1939: enhanced error handling for tightly received RTS messages
+ in xtp_rx_rts_session_new
+ - PCI/MSI: Fix UAF in msi_capability_init
+ - nvmet-fc: Remove __counted_by from nvmet_fc_tgt_queue.fod[]
+ - cpufreq: intel_pstate: Use HWP to initialize ITMT if CPPC is missing
+ - irqchip/loongson-eiointc: Use early_cpu_to_node() instead of cpu_to_node()
+ - cpu: Fix broken cmdline "nosmp" and "maxcpus=0"
+ - cpu/hotplug: Fix dynstate assignment in __cpuhp_setup_state_cpuslocked()
+ - irqchip/loongson-liointc: Set different ISRs for different cores
+ - kbuild: Install dtb files as 0644 in Makefile.dtbinst
+ - btrfs: zoned: fix initial free space detection
+ - csky, hexagon: fix broken sys_sync_file_range
+ - drm/drm_file: Fix pid refcounting race (CVE-2024-39486)
+ - drm/nouveau/dispnv04: fix null pointer dereference in nv17_tv_get_ld_modes
+ - drm/fbdev-dma: Only set smem_start is enable per module option
+ - drm/amdgpu: avoid using null object of framebuffer
+ - [x86] drm/i915/gt: Fix potential UAF by revoke of fence registers
+ - drm/nouveau/dispnv04: fix null pointer dereference in nv17_tv_get_hd_modes
+ - drm/amd/display: Send DP_TOTAL_LTTPR_CNT during detection if LTTPR is
+ present
+ - drm/amdgpu/atomfirmware: fix parsing of vram_info
+ - io_uring: signal SQPOLL task_work with TWA_SIGNAL_NO_IPI
+ - batman-adv: Don't accept TT entries for out-of-spec VIDs
+ - can: mcp251xfd: fix infinite loop when xmit fails
+ - ata: ahci: Clean up sysfs file on error
+ - ata: libata-core: Add ATA_HORKAGE_NOLPM for all Crucial BX SSD1 models
+ - ata: libata-core: Fix double free on error
+ - ftruncate: pass a signed offset
+ - syscalls: fix compat_sys_io_pgetevents_time64 usage
+ - syscalls: fix sys_fanotify_mark prototype
+ - bcachefs: Fix sb_field_downgrade validation
+ - bcachefs: Fix sb-downgrade validation
+ - bcachefs: Fix bch2_sb_downgrade_update()
+ - bcachefs: Fix setting of downgrade recovery passes/errors
+ - bcachefs: btree_gc can now handle unknown btrees
+ - Revert "net: sfp: enhance quirk for Fibrestore 2.5G copper SFP module"
+ - mm/page_alloc: Separate THP PCP into movable and non-movable categories
+ - [arm64] dts: rockchip: Fix SD NAND and eMMC init on rk3308-rock-pi-s
+ - [arm64] dts: rockchip: Rename LED related pinctrl nodes on
+ rk3308-rock-pi-s
+ - [arm64] dts: rockchip: set correct pwm0 pinctrl on rk3588-tiger
+ - [arm64] dts: rockchip: Fix the value of `dlg,jack-det-rate` mismatch on
+ rk3399-gru
+ - [arm64] Revert "arm64: dts: rockchip: remove redundant cd-gpios from
+ rk3588 sdmmc nodes"
+ - [arm64] dts: rockchip: make poweroff(8) work on Radxa ROCK 5A
+ - cxl/region: Convert cxl_pmem_region_alloc to scope-based resource
+ management
+ - cxl/mem: Fix no cxl_nvd during pmem region auto-assembling
+ - [arm64] dts: rockchip: fix PMIC interrupt pin on ROCK Pi E
+ - reset: gpio: Fix missing gpiolib dependency for GPIO reset controller
+ - [arm64] dts: rockchip: Fix the i2c address of es8316 on Cool Pi 4B
+ - [arm64] dts: rockchip: Add sound-dai-cells for RK3368
+ - cxl/region: Move cxl_dpa_to_region() work to the region driver
+ - cxl/region: Avoid null pointer dereference in region lookup
+ - cxl/region: check interleave capability
+ - netfs: Fix netfs_page_mkwrite() to check folio->mapping is valid
+ - netfs: Fix netfs_page_mkwrite() to flush conflicting data, not wait
+ - serial: imx: only set receiver level if it is zero
+ - serial: 8250_omap: Fix Errata i2310 with RX FIFO level check
+ - tracing/net_sched: NULL pointer dereference in perf_trace_qdisc_reset()
+
+ [ Salvatore Bonaccorso ]
+ * [rt] Drop "pinctrl: renesas: rzg2l: Use
+ spin_{lock,unlock}_irq{save,restore}" (applied upstream)
+ * d/rules.real: Revert workaround to explicitly remove executable bits from
+ dtb files (implemented upstream)
+
+ -- Salvatore Bonaccorso <carnil@debian.org> Sun, 07 Jul 2024 20:58:08 +0200
+
linux (6.9.7-1) unstable; urgency=medium
* New upstream stable update: