summaryrefslogtreecommitdiffstats
path: root/drivers/base/test/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/base/test/Makefile')
-rw-r--r--drivers/base/test/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/drivers/base/test/Makefile b/drivers/base/test/Makefile
new file mode 100644
index 000000000..e321dfc7e
--- /dev/null
+++ b/drivers/base/test/Makefile
@@ -0,0 +1,8 @@
+# SPDX-License-Identifier: GPL-2.0
+obj-$(CONFIG_TEST_ASYNC_DRIVER_PROBE) += test_async_driver_probe.o
+
+obj-$(CONFIG_DM_KUNIT_TEST) += root-device-test.o
+obj-$(CONFIG_DM_KUNIT_TEST) += platform-device-test.o
+
+obj-$(CONFIG_DRIVER_PE_KUNIT_TEST) += property-entry-test.o
+CFLAGS_property-entry-test.o += $(DISABLE_STRUCTLEAK_PLUGIN)