summaryrefslogtreecommitdiffstats
path: root/drivers/gpu/drm/tegra/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/gpu/drm/tegra/Makefile')
-rw-r--r--drivers/gpu/drm/tegra/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/drivers/gpu/drm/tegra/Makefile b/drivers/gpu/drm/tegra/Makefile
new file mode 100644
index 0000000000..6fc4b504e7
--- /dev/null
+++ b/drivers/gpu/drm/tegra/Makefile
@@ -0,0 +1,34 @@
+# SPDX-License-Identifier: GPL-2.0
+ccflags-$(CONFIG_DRM_TEGRA_DEBUG) += -DDEBUG
+
+tegra-drm-y := \
+ drm.o \
+ uapi.o \
+ submit.o \
+ firewall.o \
+ gem.o \
+ fb.o \
+ dp.o \
+ hub.o \
+ plane.o \
+ dc.o \
+ output.o \
+ rgb.o \
+ hda.o \
+ hdmi.o \
+ mipi-phy.o \
+ dsi.o \
+ sor.o \
+ dpaux.o \
+ gr2d.o \
+ gr3d.o \
+ falcon.o \
+ vic.o \
+ nvdec.o \
+ riscv.o
+
+tegra-drm-y += trace.o
+
+tegra-drm-$(CONFIG_DRM_FBDEV_EMULATION) += fbdev.o
+
+obj-$(CONFIG_DRM_TEGRA) += tegra-drm.o