summaryrefslogtreecommitdiffstats
path: root/drivers/gpu/drm/tests/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/gpu/drm/tests/Makefile')
-rw-r--r--drivers/gpu/drm/tests/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/drivers/gpu/drm/tests/Makefile b/drivers/gpu/drm/tests/Makefile
new file mode 100644
index 000000000..ba7baa622
--- /dev/null
+++ b/drivers/gpu/drm/tests/Makefile
@@ -0,0 +1,23 @@
+# SPDX-License-Identifier: GPL-2.0
+
+obj-$(CONFIG_DRM_KUNIT_TEST_HELPERS) += \
+ drm_kunit_helpers.o
+
+obj-$(CONFIG_DRM_KUNIT_TEST) += \
+ drm_buddy_test.o \
+ drm_cmdline_parser_test.o \
+ drm_connector_test.o \
+ drm_damage_helper_test.o \
+ drm_dp_mst_helper_test.o \
+ drm_format_helper_test.o \
+ drm_format_test.o \
+ drm_framebuffer_test.o \
+ drm_managed_test.o \
+ drm_mm_test.o \
+ drm_modes_test.o \
+ drm_plane_helper_test.o \
+ drm_probe_helper_test.o \
+ drm_rect_test.o \
+ drm_exec_test.o
+
+CFLAGS_drm_mm_test.o := $(DISABLE_STRUCTLEAK_PLUGIN)