summaryrefslogtreecommitdiffstats
path: root/drivers/i2c/algos/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/i2c/algos/Makefile')
-rw-r--r--drivers/i2c/algos/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/drivers/i2c/algos/Makefile b/drivers/i2c/algos/Makefile
new file mode 100644
index 000000000..9b319a30d
--- /dev/null
+++ b/drivers/i2c/algos/Makefile
@@ -0,0 +1,10 @@
+# SPDX-License-Identifier: GPL-2.0-only
+#
+# Makefile for the i2c algorithms
+#
+
+obj-$(CONFIG_I2C_ALGOBIT) += i2c-algo-bit.o
+obj-$(CONFIG_I2C_ALGOPCF) += i2c-algo-pcf.o
+obj-$(CONFIG_I2C_ALGOPCA) += i2c-algo-pca.o
+
+ccflags-$(CONFIG_I2C_DEBUG_ALGO) := -DDEBUG