summaryrefslogtreecommitdiffstats
path: root/drivers/interconnect/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/interconnect/Makefile')
-rw-r--r--drivers/interconnect/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/drivers/interconnect/Makefile b/drivers/interconnect/Makefile
new file mode 100644
index 000000000..d0888babb
--- /dev/null
+++ b/drivers/interconnect/Makefile
@@ -0,0 +1,11 @@
+# SPDX-License-Identifier: GPL-2.0
+
+CFLAGS_core.o := -I$(src)
+icc-core-objs := core.o bulk.o debugfs-client.o
+
+obj-$(CONFIG_INTERCONNECT) += icc-core.o
+obj-$(CONFIG_INTERCONNECT_IMX) += imx/
+obj-$(CONFIG_INTERCONNECT_QCOM) += qcom/
+obj-$(CONFIG_INTERCONNECT_SAMSUNG) += samsung/
+
+obj-$(CONFIG_INTERCONNECT_CLK) += icc-clk.o