summaryrefslogtreecommitdiffstats
path: root/drivers/misc/sgi-xp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/misc/sgi-xp/Makefile')
-rw-r--r--drivers/misc/sgi-xp/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/drivers/misc/sgi-xp/Makefile b/drivers/misc/sgi-xp/Makefile
new file mode 100644
index 0000000000..34c55a4045
--- /dev/null
+++ b/drivers/misc/sgi-xp/Makefile
@@ -0,0 +1,13 @@
+# SPDX-License-Identifier: GPL-2.0
+#
+# Makefile for SGI's XP devices.
+#
+
+obj-$(CONFIG_SGI_XP) += xp.o
+xp-y := xp_main.o xp_uv.o
+
+obj-$(CONFIG_SGI_XP) += xpc.o
+xpc-y := xpc_main.o xpc_channel.o xpc_partition.o \
+ xpc_uv.o
+
+obj-$(CONFIG_SGI_XP) += xpnet.o