summaryrefslogtreecommitdiffstats
path: root/drivers/mtd/ubi/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/mtd/ubi/Makefile')
-rw-r--r--drivers/mtd/ubi/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/drivers/mtd/ubi/Makefile b/drivers/mtd/ubi/Makefile
new file mode 100644
index 000000000..543673605
--- /dev/null
+++ b/drivers/mtd/ubi/Makefile
@@ -0,0 +1,9 @@
+# SPDX-License-Identifier: GPL-2.0
+obj-$(CONFIG_MTD_UBI) += ubi.o
+
+ubi-y += vtbl.o vmt.o upd.o build.o cdev.o kapi.o eba.o io.o wl.o attach.o
+ubi-y += misc.o debug.o
+ubi-$(CONFIG_MTD_UBI_FASTMAP) += fastmap.o
+ubi-$(CONFIG_MTD_UBI_BLOCK) += block.o
+
+obj-$(CONFIG_MTD_UBI_GLUEBI) += gluebi.o