summaryrefslogtreecommitdiffstats
path: root/drivers/net/phy/mscc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/net/phy/mscc/Makefile')
-rw-r--r--drivers/net/phy/mscc/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/drivers/net/phy/mscc/Makefile b/drivers/net/phy/mscc/Makefile
new file mode 100644
index 0000000000..78d84194f7
--- /dev/null
+++ b/drivers/net/phy/mscc/Makefile
@@ -0,0 +1,15 @@
+# SPDX-License-Identifier: GPL-2.0
+#
+# Makefile for MSCC networking PHY driver
+
+obj-$(CONFIG_MICROSEMI_PHY) := mscc.o
+mscc-objs := mscc_main.o
+mscc-objs += mscc_serdes.o
+
+ifdef CONFIG_MACSEC
+mscc-objs += mscc_macsec.o
+endif
+
+ifdef CONFIG_NETWORK_PHY_TIMESTAMPING
+mscc-objs += mscc_ptp.o
+endif