summaryrefslogtreecommitdiffstats
path: root/drivers/perf/hisilicon/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/perf/hisilicon/Makefile')
-rw-r--r--drivers/perf/hisilicon/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/drivers/perf/hisilicon/Makefile b/drivers/perf/hisilicon/Makefile
new file mode 100644
index 000000000..48dcc8381
--- /dev/null
+++ b/drivers/perf/hisilicon/Makefile
@@ -0,0 +1,7 @@
+# SPDX-License-Identifier: GPL-2.0-only
+obj-$(CONFIG_HISI_PMU) += hisi_uncore_pmu.o hisi_uncore_l3c_pmu.o \
+ hisi_uncore_hha_pmu.o hisi_uncore_ddrc_pmu.o hisi_uncore_sllc_pmu.o \
+ hisi_uncore_pa_pmu.o hisi_uncore_cpa_pmu.o hisi_uncore_uc_pmu.o
+
+obj-$(CONFIG_HISI_PCIE_PMU) += hisi_pcie_pmu.o
+obj-$(CONFIG_HNS3_PMU) += hns3_pmu.o