summaryrefslogtreecommitdiffstats
path: root/drivers/soc/renesas/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/soc/renesas/Makefile')
-rw-r--r--drivers/soc/renesas/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/drivers/soc/renesas/Makefile b/drivers/soc/renesas/Makefile
new file mode 100644
index 000000000..734f8f8ce
--- /dev/null
+++ b/drivers/soc/renesas/Makefile
@@ -0,0 +1,12 @@
+# SPDX-License-Identifier: GPL-2.0
+# Generic, must be first because of soc_device_register()
+obj-$(CONFIG_SOC_RENESAS) += renesas-soc.o
+
+# SoC
+ifdef CONFIG_SMP
+obj-$(CONFIG_ARCH_R9A06G032) += r9a06g032-smp.o
+endif
+
+# Family
+obj-$(CONFIG_PWC_RZV2M) += pwc-rzv2m.o
+obj-$(CONFIG_RST_RCAR) += rcar-rst.o