summaryrefslogtreecommitdiffstats
path: root/drivers/soc/samsung/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/soc/samsung/Makefile')
-rw-r--r--drivers/soc/samsung/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/drivers/soc/samsung/Makefile b/drivers/soc/samsung/Makefile
new file mode 100644
index 000000000..248a33d77
--- /dev/null
+++ b/drivers/soc/samsung/Makefile
@@ -0,0 +1,15 @@
+# SPDX-License-Identifier: GPL-2.0
+
+obj-$(CONFIG_EXYNOS_ASV_ARM) += exynos5422-asv.o
+obj-$(CONFIG_EXYNOS_CHIPID) += exynos_chipid.o
+exynos_chipid-y += exynos-chipid.o exynos-asv.o
+
+obj-$(CONFIG_EXYNOS_USI) += exynos-usi.o
+
+obj-$(CONFIG_EXYNOS_PMU) += exynos-pmu.o
+
+obj-$(CONFIG_EXYNOS_PMU_ARM_DRIVERS) += exynos3250-pmu.o exynos4-pmu.o \
+ exynos5250-pmu.o exynos5420-pmu.o
+obj-$(CONFIG_EXYNOS_REGULATOR_COUPLER) += exynos-regulator-coupler.o
+
+obj-$(CONFIG_SAMSUNG_PM_CHECK) += s3c-pm-check.o